Bug 598443 - System will not boot if I hit Esc during plymouth
Summary: System will not boot if I hit Esc during plymouth
Status: CLOSED DUPLICATE of bug 515413
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 12:18 UTC by Miroslav Suchý
Modified: 2010-06-01 15:44 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-01 14:30:46 UTC


Attachments (Terms of Use)
screenshot of screen after I went 3 several times from plymouth theme to text console and back (853.97 KB, image/jpeg)
2010-06-01 12:19 UTC, Miroslav Suchý
no flags Details

Description Miroslav Suchý 2010-06-01 12:18:20 UTC
Description of problem:
When I hit Esc during boot to see which service starts etc. I see only "Starting udev" and nothing more. No progress. When I hit Esc again I got back to ring theme of plymouth, but the rings are stuck. Nearly they move very very slow. I wait several minutes and saw no progress. If I hit Esc again, then "starting udev" message is duplicated, but nothing more.
If I do not touch Esc during boot, then system will boot up as usual. 

Version-Release number of selected component (if applicable):
# rpm -qa |grep plymou
plymouth-graphics-libs-0.8.3-3.el6.x86_64
plymouth-debuginfo-0.8.3-3.el6.x86_64
plymouth-theme-rings-0.8.3-3.el6.x86_64
plymouth-theme-glow-0.8.2-3.el6.x86_64
plymouth-plugin-label-0.8.3-3.el6.x86_64
plymouth-system-theme-0.8.3-3.el6.x86_64
plymouth-scripts-0.8.3-3.el6.x86_64
plymouth-core-libs-0.8.3-3.el6.x86_64
plymouth-plugin-two-step-0.8.3-3.el6.x86_64
plymouth-utils-0.8.3-3.el6.x86_64
plymouth-0.8.3-3.el6.x86_64
# rpm -q kernel
kernel-2.6.32-28.el6.x86_64
kernel-2.6.32-29.el6.x86_64
kernel-2.6.32-31.el6.x86_64

How reproducible:
I done it twice in row.

Steps to Reproduce:
1. boot
2. hit Esc - I usually done it when the inner ring was in position 3 o'clock
  
Actual results:
no messages from startup is seen
when return back to plymouth the rings move very very slow

Expected results:
I see which services are starting.
after second Esc I see plymouth theme with normal progress.

Additional info:

Comment 1 Miroslav Suchý 2010-06-01 12:19:48 UTC
Created attachment 418612 [details]
screenshot of screen after I went 3 several times from plymouth theme to text console and back

Comment 2 RHEL Product and Program Management 2010-06-01 12:35:54 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Ray Strode [halfline] 2010-06-01 14:30:46 UTC
You're seeing two separate bugs here:

1) system not booting: bug 515413
2) Weird rendering artifact bug 598448

Marking this as a duplicate of the first one, since it's the most severe

*** This bug has been marked as a duplicate of bug 515413 ***

Comment 4 Jon Masters 2010-06-01 15:44:48 UTC
Sorry about that! Should be ok in the next nightly.


Note You need to log in before you can comment on or make changes to this bug.