Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598535 - the gnome-keyring-daemon needs proper locking around memory allocations functions
the gnome-keyring-daemon needs proper locking around memory allocations funct...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 11:16 EDT by Fabrice Bellet
Modified: 2015-03-03 17:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 12:51:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add locking for memory ops in the gkd (802 bytes, patch)
2010-06-01 11:18 EDT, Fabrice Bellet
no flags Details | Diff

  None (edit)
Description Fabrice Bellet 2010-06-01 11:16:40 EDT
the gnome-keyring-daemon crashes frequently in egg-secure-memory.c, specifically when it is used as a ssh agent, with a lot of concurrent ssh sessions. The memory allocation functions in egg/egg-secure-memory.c are protected by DO_LOCK() / DO_UNLOCK() macros, with appear to be no-op in the case of the gnome-keyring-daemon (daemon/gkd-main.c), which is probably not a good idea, because it works in a threaded environment when creating client threads in gkd_ssh_agent_accept().

So I think a real locking should be added in daemon/gkd-main.c

patch is attached.
Comment 1 Fabrice Bellet 2010-06-01 11:18:00 EDT
Created attachment 418678 [details]
patch to add locking for memory ops in the gkd
Comment 2 Fabrice Bellet 2010-06-29 12:51:07 EDT
This is fixed in 2.30.3. thanks!

Note You need to log in before you can comment on or make changes to this bug.