Bug 598594 - missing mount.cifs (cifs-utils) after yum upgrade
Summary: missing mount.cifs (cifs-utils) after yum upgrade
Status: CLOSED DUPLICATE of bug 558368
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 17:04 UTC by Henrique Martins
Modified: 2011-04-04 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-04 16:49:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrique Martins 2010-06-01 17:04:22 UTC
Description of problem:
Yum upgrade from Fedora 12 to 13 on a x86_64 system seems to have deleted mount.cifs from my system and that made a few things fail.  Seems it is part of cifs-utils, which wasn't installed by the upgrade.

Looks like there's a cifs.ko module that is invoked on a mount, but that one kept claiming that no username was specified and thus mount would fail.

Version-Release number of selected component (if applicable):
missing a release installed 4.4-3

How reproducible:
Don't know, as I can't back out to Fedora 12 to try it.

Steps to Reproduce:
1. yum upgrade from f12 to f13
2. try to mount a cifs share
3.
  
Actual results:
CIFS VFS: cifs_mount failed w/return code = -22
CIFS VFS: No username specified

Expected results:
mount successful

Additional info:
After installing cifs-utils, everything works as before.

Comment 1 Jeff Layton 2010-06-01 17:24:26 UTC
After a brief chat with Simo, he agrees that the right way to fix this is to have the samba-client package carry a dependency on cifs-utils. It would be nice if there were another way to do this, but RPM sort of constrains us here.

I think after a few releases have gone by then we should be able to remove the dependency (I'm thinking F16).

Comment 2 Henrique Martins 2010-06-01 18:20:52 UTC
Can't look ahead that far (18~20 months?) but does this mean that mount.cifs disappears by then and cifs.ko will handle smb client mounts as mount.cifs does now?

Comment 3 Jeff Layton 2010-06-01 18:33:23 UTC
No, this would simply be a packaging change to ease us over the transition to a separate cifs-utils package. At some point, we wouldn't reasonably expect someone to attempt an upgrade across too many releases and at that point we can just remove the dependency.

I'd assert that an upgrade from F13 directly to F16 wouldn't be an expected activity and so at that point we won't need the samba-client package to carry the dependency any longer. Anyone will either be doing a new install or would do an intermediate upgrade to a different release.

Comment 4 Fedora Admin XMLRPC Client 2010-10-08 14:43:28 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Simo Sorce 2011-04-04 16:49:10 UTC

*** This bug has been marked as a duplicate of bug 558368 ***


Note You need to log in before you can comment on or make changes to this bug.