Bug 59860 - Auto partitioning could do better for /boot
Auto partitioning could do better for /boot
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 18:10 EST by Alexandre Oliva
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-02-13 18:10:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
I now have a 39-MB chunk of free space (4 cylinders) in the 1017-1021 cylinder
range, and 5GB at the end of the disk (cyl 5200-5836).  Nevertheless, if I tell
the installer to auto-partition while preserving existing partitions, it chooses
to use the 5200-5205 range and warn me about the likelyhood that it won't work,
instead of using the available yet smaller range for /boot that would work just
fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.resize the existing /boot partition such that about 40MB become free in the
<1024 range
2.make sure there's no additional free space around in that range, and `enough'
space for the installation elsewhere
3.choose automatic partitioning preserving existing partitions
	

Actual Results:  it takes disk space from `elsewhere' for /boot, instead of
using the existing space

Expected Results:  it should at least offer to use the smaller-than-recommended
partition instead of committing to an installation that won't work.

Ideally, I'd like to use the same /boot partition for multiple installations,
each in a separate sub-directory, but this may be asking for too much :-)

Additional info:
Comment 1 Michael Fulbright 2002-03-26 12:31:12 EST
Deferring to future release.
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.