Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598604 - Installing /boot to a RAID1 will not boot
Installing /boot to a RAID1 will not boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 13:29 EDT by Brian Lane
Modified: 2010-06-01 16:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 16:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-06-01 13:29:57 EDT
Description of problem:
In F13 (and rawhide) RAID installs mdadm is using v1.1 metadata which places the superblock at the start of the partition. This differs from < 1.1 metadata which placed it at the end of the partition.

Previously you could create a RAID1 array for / with no separate /boot partition and grub would boot it because it looks at the start of the partition for the filesystem. With v1.1 metadata the start of the filesystem is offset by 2M (I think) so grub, which doesn't know anything about RAID, cannot find it.

Version-Release number of selected component (if applicable):
anaconda-13.42-1

How reproducible:
Always

Steps to Reproduce:
1. Create RAID1 array
2. Create / ext4 filesystem on array
3. Do not create a separate /boot partition
4. Install minimal system
5. reboot
  

To fix this I think we should add some checks to anaconda when installing on RAID1. 

If there is no /boot partition and if / is on a RAID1 we should fall back to using v1.0 metadata if there are no other restrictions. I need to check, but I think the big difference between v1.0 and 1.1 is support for larger partitions.

If / is on RAID level other than 1 and there is no separate /boot the user should be warned that it will be unbootable. Also warn if v1.0 metadata cannot be used.
Comment 1 Brian Lane 2010-06-01 16:23:17 EDT
This is a problem on Fedora13, it has already been addressed on rawhide by hansg with commit 13f66ffc03cc66946a730079dba6ea6e2d10c737

Note You need to log in before you can comment on or make changes to this bug.