Bug 59865 - Disk Druid: can't edit `Free Space' into /boot
Disk Druid: can't edit `Free Space' into /boot
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 18:54 EST by Alexandre Oliva
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-02-13 18:54:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
When I choose to edit a chunk of Free Space in the <1024 range into /boot, it
says `Could not allocated requested partitions: partitioning failed: could not
allocated cylinder-based partitions as primary partitions, even though `Force to
be a primary partition' was not checked.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.make up some 40MB of free space in the <1024 cylinder range with parted or
something alike
2.in the text-mode disk druid, select that Free Space and type ENTER
3.choose ext3, go back to the mount point and enter /boot, then ok
	

Actual Results:  It displays the error message above.

Expected Results:  It should turn the chunk of free space into the selected
partition

Additional info:

After having successfully created /boot with `New', leaving one free cylinder, I
could successfully edit the remaining chunk of free space into a new ext3
partition.  I don't know whether there's something special about /boot or some
other particularity of my partition table (such as the fact that the new
partition would have to be called /dev/hda9, but it would be physically before
/dev/hda5, and the first one in the chunk reserved for hda4, an extended partition.
Comment 1 Alexandre Oliva 2002-03-10 07:09:53 EST
Remains in beta2.
Comment 2 Michael Fulbright 2002-03-26 12:31:45 EST
Deferring to future release.
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.