Bug 598658 - libsemanage.semanage_install_active: setfiles returned error code 1 installing 3.7.19-22.fc13
libsemanage.semanage_install_active: setfiles returned error code 1 installin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 15:44 EDT by Orion Poplawski
Modified: 2010-06-08 15:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-23.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 15:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2010-06-01 15:44:23 EDT
Description of problem:

I had to run the scriptlet by hand to see the full errors:

libsepol.context_from_record: type httpd_sys_rw_content_rw_t is not defined
libsepol.context_from_record: could not create context structure
libsepol.context_from_string: could not create context structure
libsepol.sepol_context_to_sid: could not convert system_u:object_r:httpd_sys_rw_content_rw_t:s0 to sid
invalid context system_u:object_r:httpd_sys_rw_content_rw_t:s0
libsemanage.semanage_install_active: setfiles returned error code 1.
semodule:  Failed!

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.7.19-22.fc13.noarch
Comment 1 Daniel Walsh 2010-06-01 16:43:24 EDT
Miroslav, this line is wrong.

+/etc/dokuwiki(/.*)?			gen_context(system_u:object_r:httpd_sys_rw_content_rw_t,s0)


Please fix and replace the 22 build in koji.
Comment 2 Daniel Walsh 2010-06-01 16:45:45 EDT
Looks like this is fixed in selinux-policy-3.7.19-23.fc13


Orion can you pull this build out of koji?
Comment 3 Miroslav Grepl 2010-06-02 04:34:38 EDT
Yes, it is fixed in selinux-policy-3.7.19-23.fc13.
Comment 5 Fedora Update System 2010-06-02 05:04:43 EDT
selinux-policy-3.7.19-23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-23.fc13
Comment 6 Fedora Update System 2010-06-02 14:13:15 EDT
selinux-policy-3.7.19-23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-23.fc13
Comment 7 Fedora Update System 2010-06-08 15:27:16 EDT
selinux-policy-3.7.19-23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.