This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 59869 - running executable from an nfs mounted filesystem segmentation fault (s) if not mounted.
running executable from an nfs mounted filesystem segmentation fault (s) if n...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Moyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 20:41 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 20:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-13 20:41:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
When running a script that loads an executable image on a dual 1.2ghz processor
Athlon system, the program will fail with a segmentation fault on the load, if
the file system isn't mounted. If you mount the file system first, the load
works every time. I suspect that there may be a bug in mount on dual processor
machines. I have a core file, if you need it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. place a large executable on an nfs exported file system which is handled by
the automounter (nis maps)
2. run a script that runs the executable.. if the file system is
unmounted, it fails.  
3. If you run it again, before the automounter unmounts it, it
runs fine.

4. to provoke it again before the automatic unmount, do a hand
unmount of the file system.
	

Actual Results:  /apps/synopsys/cur/linux/syn/bin/dc_shell-t: line 4:  1513
Segmentation fault      (core dumped) ${exec_name} -tcl_mode -r ${synopsys_root}
"$@

Expected Results:  the task should run

Additional info:

I've tried to add "hard intr" to the mount to see if that helps. No
change.

I was not able to reproduce the bug on 7.2. (The third party
application is certified on 7.1)
Comment 1 Need Real Name 2002-03-15 19:12:23 EST
Switching to a uniprocessor OS causes the problem to stop.. This seems
to point pretty solidly to a race condition in the SMP version of the
OS.

Thanks
Comment 2 Jeff Moyer 2004-03-30 19:49:24 EST
Is this reproducable on fedora or a RHEL variant?  If not, I will
close as current release.
Comment 3 Need Real Name 2004-03-30 20:00:23 EST
It's so old that it can be closed.. 

FYI.. despite buying support for these machines, this is the FIRST
contact I've had with ANYONE since I opened the problem in 2002!!!!

I'm REALLY disapointed with Redhat's support in this regard!

Note You need to log in before you can comment on or make changes to this bug.