Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598697 - "Show debug and development software sources" tick broken
"Show debug and development software sources" tick broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 591663 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 16:51 EDT by Sandro Mani
Modified: 2010-06-18 10:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: PackageKit-0.6.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 15:15:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gpk-application --verbose (6.68 KB, text/plain)
2010-06-01 16:51 EDT, Sandro Mani
no flags Details
pkmon --verbose (3.58 KB, text/plain)
2010-06-01 16:51 EDT, Sandro Mani
no flags Details

  None (edit)
Description Sandro Mani 2010-06-01 16:51:23 EDT
Created attachment 418819 [details]
gpk-application --verbose

Description of problem:
The "Show debug and development software sources" tick has no effect anymore (used to work in F12) - dev and debug repos are always shown.

Version-Release number of selected component (if applicable):
gnome-packagekit-2.30.2-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. System -> Administration -> Add/Remove Software -> System -> Software Sources
2.
3.
  
Actual results:
Tick has no effect

Expected results:
Tick should toggle the indicated repos

Additional info:
gpk-application --verbose and pkmon --verbose don't appear to give out anything interesting, outputs attached just in case (for test case open gpk-application, open software sources dialog, toggle tick to unselected and then to selected again, then close dialog and main window)
Comment 1 Sandro Mani 2010-06-01 16:51:50 EDT
Created attachment 418820 [details]
pkmon --verbose
Comment 2 Richard Hughes 2010-06-02 04:21:32 EDT
commit 72a5f91e354697c53ac82d91b348d627fdf52c1f
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Jun 2 09:20:34 2010 +0100

    yum: Fix up the filter check when doing GetRepoList(). Fixes rh#598697

I'll do a new release this week an push to F13. Thanks for reporting this bug.
Comment 3 Fedora Update System 2010-06-02 07:13:27 EDT
PackageKit-0.6.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/PackageKit-0.6.5-1.fc13
Comment 4 Fedora Update System 2010-06-03 14:08:44 EDT
PackageKit-0.6.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/PackageKit-0.6.5-1.fc13
Comment 5 Fedora Update System 2010-06-10 15:15:22 EDT
PackageKit-0.6.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Richard Hughes 2010-06-18 10:52:34 EDT
*** Bug 591663 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.