Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598776 - fsstress on btrfs may cause kernel bug and panic
fsstress on btrfs may cause kernel bug and panic
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Josef Bacik
Red Hat Kernel QE team
:
Depends On:
Blocks: 584197
  Show dependency treegraph
 
Reported: 2010-06-01 22:37 EDT by Eryu Guan
Modified: 2010-07-15 14:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 14:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fsstress panic log (8.96 KB, application/octet-stream)
2010-06-01 22:37 EDT, Eryu Guan
no flags Details

  None (edit)
Description Eryu Guan 2010-06-01 22:37:03 EDT
Created attachment 418880 [details]
fsstress panic log

Description of problem:
Run fsstress test on btrfs may cause kernel bug and panic.
Attachment is console log.

Version-Release number of selected component (if applicable):
[root@amd-drachma-01 ~]# uname -a
Linux amd-drachma-01.lab.bos.redhat.com 2.6.32-27.el6.x86_64 #1 SMP Tue May 18 12:25:26 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@amd-drachma-01 ~]# rpm -q btrfs-progs nfs-utils rpcbind
btrfs-progs-0.19-10.el6.x86_64
nfs-utils-1.2.2-2.el6.x86_64
rpcbind-0.2.0-4.1.el6.x86_64

Also on RHEL6.0-Snapshot-5, that is 2.6.32-28.el6.x86_64

How reproducible:
About 50%

Steps to Reproduce:
1. Schedule /kernel/filesystems/btrfs/fsstress in rhts or beaker

2. Or yum install rh-tests-kernel-filesystems-btrfs-fsstress
   then cd to /mnt/tests/kernel/filesystems/btrfs/fsstress, make run manually
  
Actual results:
kernel bug and panic

Expected results:
Pass test all the time

Additional info:
rhts job link
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=160738
beaker job link
https://beaker.engineering.redhat.com/jobs/1373

And there is a PASS test in beaker, but fsstress process may be stuck.
https://beaker.engineering.redhat.com/jobs/1388
https://beaker.engineering.redhat.com/logs/2010/88/1388/2558/24768/113246///console_dmesg--kernel-filesystems-btrfs-fsstress.log
Comment 2 Eric Sandeen 2010-06-02 08:29:48 EDT
It looks like there was not actually a bug or a panic, but there was a soft lockup and a WARNING due to list corruption, which is bad enough ...
Comment 3 RHEL Product and Program Management 2010-06-07 12:21:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 RHEL Product and Program Management 2010-07-15 11:08:57 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Ric Wheeler 2010-07-15 13:52:04 EDT
Josef, can you validate that this does not happen in the current 6.0 builds and close it if not?  If it is still an issue, we should reflag this for 6.1 since we are not going to have tech preview items be blockers unless really severe.

Thanks!
Comment 6 Josef Bacik 2010-07-15 14:04:53 EDT
I ran xfstests against the updated btrfs in RHEL6 and I didn't get any panics (it runs fsstress), so I'm going to close this.

Note You need to log in before you can comment on or make changes to this bug.