This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 59878 - Mailman sends malformed digest.
Mailman sends malformed digest.
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-14 08:48 EST by David Woodhouse
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 14:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
offending outgoing message. (21.00 KB, message/rfc822)
2002-02-14 08:49 EST, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2002-02-14 08:48:26 EST
When mailman sends a digest including 8-bit messages, it fails to add a
Content-Transfer-Encoding header, and just sends 8-bit data with no indication
that it's doing so. This violates RFC2045 and causes the mail to be rejected by
some mail servers.
Comment 1 David Woodhouse 2002-02-14 08:49:41 EST
Created attachment 45680 [details]
offending outgoing message.
Comment 2 John Dennis 2005-02-15 14:54:19 EST
O.K., I've done a bunch of testing on the current mailman version,
2.1.5 and as far as I can tell its handling this correctly (on the
assumption it receives a correctly encoded email message).

When a receipient is set to receive a mime digest the multipart
components in the multipart/digest is getting the
Content-Transfer-Encoding copied into it from the original email message. 

When set to plain digest the non-7bit chars are stripped out.

When rfc 2047 encoded words appear in an email header the summary
section reduces the encoded word to a "?" in 7bit ascii

All seems to be well in FC1,FC2,FC3,FC4,RHEL3,RHEL4

Note You need to log in before you can comment on or make changes to this bug.