Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598900 - NM should automatically handle network proxy details.
NM should automatically handle network proxy details.
Status: CLOSED DUPLICATE of bug 576149
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 06:10 EDT by Rodd Clarkson
Modified: 2010-08-17 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 12:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2010-06-02 06:10:01 EDT
Description of problem:

I work at a number of locations (schools in my case) where they have wireless and wired connections along with specific network proxy setups.

At the moment as I move from site to site I have to go to System > Preferences > Network Proxy and select the appropriate settings for the site I'm at.  While this isn't complex, you have to remember to do it.

It would be fantastic if the 'Network Connections' settings included a Proxy Settings tab for each connection that allowed you to select from your Network Proxy Settings above and which it automatically used when you connect.

I guess it would make sense that when you disconnect, the Network Proxy Settings returned to 'default' again, so that you don't have to specify the proxy settings for each connection type.

Obviously, it might be nice to prompt for Proxy Settings when adding new connections, but some sort of limited proxy management would be a huge bonus for those of us with a range of proxy settings at various sites.

Version-Release number of selected component (if applicable):

Current f13 NM, but really current NW I guess.
Comment 1 Dan Williams 2010-08-17 12:34:36 EDT

*** This bug has been marked as a duplicate of bug 576149 ***

Note You need to log in before you can comment on or make changes to this bug.