Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598913 - [abrt] crash in thunderbird-3.0.4-3.fc13: Process /usr/lib/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
[abrt] crash in thunderbird-3.0.4-3.fc13: Process /usr/lib/thunderbird-3.0/th...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
abrt_hash:b76f92fc36a2753a5686a4399d3...
:
: 609095 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 06:43 EDT by Daniel Medianero
Modified: 2018-04-11 06:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 20:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (81.73 KB, text/plain)
2010-06-02 06:43 EDT, Daniel Medianero
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 526935 None None None Never

  None (edit)
Description Daniel Medianero 2010-06-02 06:43:10 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/thunderbird-3.0/thunderbird-bin
component: thunderbird
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib/thunderbird-3.0/thunderbird-bin
global_uuid: b76f92fc36a2753a5686a4399d3b0788410cefdc
kernel: 2.6.33.5-112.fc13.i686
package: thunderbird-3.0.4-3.fc13
rating: 4
reason: Process /usr/lib/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Daniel Medianero 2010-06-02 06:43:14 EDT
Created attachment 418984 [details]
File: backtrace
Comment 2 Matěj Cepl 2010-07-28 09:09:17 EDT
#3  <signal handler called>
No symbol table info available.
#4  0x0394c779 in nsMsgDBView::NoteChange (this=0xad23e400, firstLineChanged=
    1, numChanged=2, changeType=2)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgDBView.cpp:5774
No locals.
#5  0x0396416e in nsMsgXFViewThread::RemoveChildHdr (this=0xb1cf9d00, child=
    0xb1f36380, announcer=0x0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgXFViewThread.cpp:346
        levelRemoved = 118 'v'
        i = <value optimized out>
        childIndex = 0
        msgKey = 775888246
        msgFolder = {<nsCOMPtr_base> = {mRawPtr = 
    0xad198100}, <No data fields>}
        date = 1275473138
#6  0x039608bb in nsMsgSearchDBView::OnHdrDeleted (this=0xa75bf800, 
    aHdrDeleted=0xb1f36380, aParentKey=4294967295, aFlags=9, aInstigator=0x0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/base/src/nsMsgSearchDBView.cpp:266
        viewThread = 0xb1cf9d00
        deletedIndex = 4
        savedFlags = 1
        thread = {<nsCOMPtr_base> = {mRawPtr = 0xb1cf9d00}, <No data fields>}
#7  0x039fcda0 in nsMsgDatabase::NotifyHdrDeletedAll (this=0xb3017bf0, 
    aHdrDeleted=0xb1f36380, aParentKey=4294967295, aFlags=9, aInstigator=0x0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/db/msgdb/src/nsMsgDatabase.cpp:724
        iter = 
    {<nsAutoTObserverArray<nsCOMPtr<nsIDBChangeListener>, 0u>::Iterator> = 
    {<nsTObserverArray_base::Iterator_base> = {mPosition = 3, mNext = 0x0}, 
            mArray = @0xb3017c38}, <No data fields>}
        listener = {<nsCOMPtr_base> = {mRawPtr = 
    0xa75bf804}, <No data fields>}
#8  0x039fb1f3 in nsMsgDatabase::DeleteHeader (this=0xb3017bf0, msg=
    0xb1f36380, instigator=0x0, commit=0, notify=1)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/db/msgdb/src/nsMsgDatabase.cpp:1807
        key = 775888246
        hdrWasNew = 0
        flags = 9
        threadParent = 4294967295
        ret = <value optimized out>
        msgHdr = 0xb1f36380
#9  0x039a0258 in nsMsgLocalMailFolder::DeleteMessage (this=0xad1980e0, 
    message=0xb1f36380, msgWindow=0xa73491f0, deleteStorage=1, commit=0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/local/src/nsLocalMailFolder.cpp:2265
        msgDBHdr = {<nsCOMPtr_base> = {mRawPtr = 
    0xb1f36380}, <No data fields>}
        rv = 0
#10 0x039a41d9 in nsMsgLocalMailFolder::DeleteMessages (this=0xad1980e0,
Comment 3 Matěj Cepl 2010-07-28 10:08:33 EDT
*** Bug 609095 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2010-07-29 20:52:52 EDT
We found this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=526935) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.