Bug 598961 - please update to syslog-ng version 3.1.X
please update to syslog-ng version 3.1.X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: syslog-ng (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On: 618033
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 08:33 EDT by Peter Czanik
Modified: 2010-07-27 15:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 15:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Czanik 2010-06-02 08:33:32 EDT
Description of problem:

syslog-ng included in FC 13 and rawhide are quite old, a new major version with many new features is available.

Currently 2.1.4 is provided, 3.1.1 is available. For changes plese check:

http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.0.5/changelog-en.txt
http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/3.1.0/changelog-en.txt

Info from the packagers point of view:

- addition of new utilities:
/usr/bin/pdbtool
/usr/sbin/syslog-ng-ctl

- apparmor (or SElinux in case of Fedora) needs some extra permissions:
/var/run/syslog-ng.ctl rw,
capability sys_tty_config,
changing rlimit

I updated the current 2.1 spec file and syslog-ng.conf to 3.1.1, built and tested it on FC 12, 13 and rawhide.

Additional info:

I work for the upstream developer and ready to help :)
Comment 1 Peter Czanik 2010-06-02 08:46:27 EDT
Almost forgot, the sources are available at
http://peter.czanik.hu/syslog-ng3.tgz
"rpmbuild -bs syslog-ng.spec" is your friend, if you want a source rpm,
I did not want to upload that for three releases...
Comment 2 Douglas E. Warner 2010-06-11 08:09:16 EDT
Do you have patched specs to upgrade what's in Fedora to the latest stable version?  This would be the most helpful rather than providing a upstream-provided spec that probably doesn't share the same history and formatting.
Comment 3 Peter Czanik 2010-06-11 08:20:29 EDT
This is not the upstream spec file, this is taken from Fedora 12, and the only changes made are those necessary to build v3.1.1 instead of v2.1.
Comment 4 Douglas E. Warner 2010-06-11 08:56:53 EDT
Then can you please post the spec file separate from the tarball?  It's much easier to work with just the spec file and download the source from upstream rather than using a patched source tarball.
Comment 5 Peter Czanik 2010-06-11 09:24:05 EDT
It is not a patches source tarball. Here is the content of the file. As you can see, everything from the original fedora source rpm, with a modified syslog-ng.spec and syslog-ng.conf and obviously the source tarball was replaced. AFAIR, only these three files were touched.

Two things are missing:
- I did not provide a changelog
- I don't know SElinux, so I did not provide updated SElinux rules for socket access and rlimit

Changes were:
- update from 2.1.X to 3.1.X
- enabled pcre support
- added the new utilities to spec file
- updated syslog-ng.conf to the new syntax

I deleted rawhide due to being short on disk space, so I can't check it right now, but the following two features could also be added:
- ssl support, if it was really moved to / as was planned a month ago
- libdbi support if it could be statically linked from /usr/lib, so logging to databases would be possible

And the content of the tarball:

# tar tzvpf syslog-ng3.tgz
drwxr-xr-x  0 root   root        0 Jun  2 10:43 src3/
-rw-r--r--  0 root   root      117 Jun  2 10:43 src3/sysklogd-syslog-ng.sysconfig
-rw-r--r--  0 root   root   700577 Jun  2 10:43 src3/syslog-ng_3.1.1.tar.gz
-rw-r--r--  0 root   root     2146 Jun  2 10:43 src3/syslog-ng.conf
-rw-r--r--  0 root   root     2509 Jun  2 10:43 src3/syslog-ng.init.d
-rw-r--r--  0 root   root      306 Jun  2 10:43 src3/sysklogd-1.4.1-44-logrotate.d-syslog.log
-rw-r--r--  0 root   root      117 Jun  2 10:43 src3/rsyslog-syslog-ng-fc10.sysconfig
-rw-r--r--  0 root   root      236 Jun  2 10:43 src3/rsyslog-3.14.1-logrotate.d-rsyslog.log
-rw-r--r--  0 root   root    17843 Jun  2 10:43 src3/syslog-ng.spec
-rw-r--r--  0 root   root      228 Jun  2 10:43 src3/rsyslog-3.21.9-logrotate.d-rsyslog.log
-rw-r--r--  0 root   root      697 Jun  2 10:43 src3/syslog-ng-2.1.4-libnet.patch
-rw-r--r--  0 root   root      228 Jun  2 10:43 src3/sysklogd-1.4.1-logrotate.d-syslog.log
-rw-r--r--  0 root   root      118 Jun  2 10:43 src3/rsyslog-syslog-ng.sysconfig

Of course, I can make another tarball with just a spec and conf file, if you want.
Comment 6 Peter Czanik 2010-06-11 16:31:12 EDT
I hope, this helps:

# tar czvpf ../syslog-ng3_conf_spec.tgz syslog-ng.conf syslog-ng.spec
a syslog-ng.conf
a syslog-ng.spec

It is now available at: http://peter.czanik.hu/syslog-ng3_conf_spec.tgz
Comment 7 Peter Czanik 2010-06-29 08:21:15 EDT
ping...

A diff of the two source directories:
http://peter.czanik.hu/syslog-ng-2to3.diff

And a source rpm for rawhide, tested and working on rawhide from today (Tue Jun 29 14:14:13 CEST 2010)
http://peter.czanik.hu/syslog-ng-3.1.1-1.fc14.src.rpm

There is one problem left to be fixed, but that's not in the syslog-ng package, and I don't know SElinux to fix it:

Jun 29 14:02:59 fedora13 setroubleshoot: SELinux is preventing /sbin/syslog-ng "create" access on sy
slog-ng.ctl. For complete SELinux messages. run sealert -l 0265df83-34bc-4a08-80c8-552005603469

Syslog-ng3 needs full access to /var/lib/syslog-ng/syslog-ng.ctl

Anything more I could help? (asked this also a week ago by e-mail, no answer...)
Comment 8 Kevin Kofler 2010-07-02 21:42:58 EDT
Ping? Any reason why this has still not been acted on?
Comment 9 Douglas E. Warner 2010-07-02 21:59:23 EDT
Just me finding the time to do it (sorry, bugzilla was down the last time I tried to respond then I forgot again).
Comment 10 Peter Czanik 2010-07-20 03:29:38 EDT
Feature freeze is nearing. Anything more I could help to get syslog-ng updated on time?
Comment 11 Douglas E. Warner 2010-07-24 15:01:36 EDT
I'm doing a local mock build right now with your changes, Peter.  I'll push a build to rawhide soon if things look good.
Comment 12 Douglas E. Warner 2010-07-24 15:01:49 EDT
I'm doing a local mock build right now with your changes, Peter.  I'll push a build to rawhide soon if things look good.
Comment 13 Douglas E. Warner 2010-07-24 19:01:21 EDT
I've built new packages for F-11, 12, 13, and 14 in my local repo; you can check them out here (still syncing right now):

http://www.silfreed.net/download/repo/packages/syslog-ng/

I'll try to take a look at these this evening and get them installed to try them out; when they check out good I'll push the changes to rawhide.
Comment 14 Douglas E. Warner 2010-07-25 15:28:03 EDT
There are new selinux permissions that will need updated; I'm filing a bug to get these added.
Comment 15 Douglas E. Warner 2010-07-25 15:37:20 EDT
Other than the selinux permissions, things are looking pretty good.  I need to finalize the changelog and I'll get things committed to rawhide and building.

Sorry for the delays :'(
Comment 16 Douglas E. Warner 2010-07-27 15:00:32 EDT
Looks like everything built.

Note You need to log in before you can comment on or make changes to this bug.