Bug 598991 - AS 5 - Creation of JMS Q failed
AS 5 - Creation of JMS Q failed
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Mac OS
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: jon-sprint11-bugs
  Show dependency treegraph
 
Reported: 2010-06-02 09:49 EDT by Heiko W. Rupp
Modified: 2013-08-05 20:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 08:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of debugger variables (55.48 KB, image/png)
2010-06-04 05:53 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Heiko W. Rupp 2010-06-02 09:49:09 EDT
Description of problem:

Tried to create a JMS Queue. This failed with 

java.lang.reflect.InvocationTargetException:null -> java.lang.RuntimeException:Failed to process template. -> java.io.FileNotFoundException:/var/folders/m9/m9pXAK2WHoyq22G2P9J8LTI/-Tmp-/JmsDestinationTemplate6780606229493193287-service.xml

snert:~ hrupp$ ls /var/folders/m9/m9pXAK2WHoyq22G2P9J8L++++TI/-Tmp-/
25f6ca5f-128f808e80a--6c31567341063383340175.upload     Jetty_0_0_0_0_50090_secondary____y6aanv
3F2B3850-4B74-4B2F-94AD-5AC60CB8F42D                    MediaCache
Jetty_0_0_0_0_50030_job____yn7qmk                       com.apple.notify.196.22
Jetty_0_0_0_0_50060_task____.2vcltf                     hsperfdata_hrupp
Jetty_0_0_0_0_50070_hdfs____w2cu08                      sprite.jpg
Jetty_0_0_0_0_50075_datanode____hwtdwq
Comment 1 Heiko W. Rupp 2010-06-04 05:53:58 EDT
Created attachment 421180 [details]
Screenshot of debugger variables

Looks like for some reasons there are spaces in the temp file path, that may no be correctly handled.
Exception happens in CreateChildResourceFacetDelegate:103

  managementView.applyTemplate(componentName, template);


EAP 5.0.1 server log shows

2010-06-04 11:49:51,253 DEBUG [org.jboss.profileservice.management.client.upload.StreamingDeploymentTarget] (WorkerThread#1
[172.31.7.7:51719]) Begin distribute: names=[queue_MyQ-service.xml], copyContent=true, description=vfsfile:/var/folders/m9/m9pXAK2WHoyq22G2P9J8L++++TI/-Tmp-/JmsDestinationTemplate1027497348895621707-service.xml

snert:~ hrupp$ ls /var/folders/m9/m9pXAK2WHoyq22G2P9J8L++++TI/-Tmp-/JmsDestinationTemplate1027497348895621707-service.xml
ls: /var/folders/m9/m9pXAK2WHoyq22G2P9J8L++++TI/-Tmp-/JmsDestinationTemplate1027497348895621707-service.xml: No such file or directory
snert:~ hrupp$ ls /var/folders/m9/m9pXAK2WHoyq22G2P9J8L++++TI/-Tmp-/
25f6ca5f-128f808e80a--6c31567341063383340175.upload     Jetty_0_0_0_0_50090_secondary____y6aanv
3F2B3850-4B74-4B2F-94AD-5AC60CB8F42D                    MediaCache
Jetty_0_0_0_0_50030_job____yn7qmk                       WebStartIcon_90470
Jetty_0_0_0_0_50060_task____.2vcltf                     com.apple.notify.196.22
Jetty_0_0_0_0_50070_hdfs____w2cu08                      hsperfdata_hrupp
Jetty_0_0_0_0_50075_datanode____hwtdwq                  sprite.jpg


So this looks very much like an issue with in EAP 5.0.1 that we can't do anything about in RHQ.
Comment 2 Heiko W. Rupp 2010-06-04 09:13:09 EDT
This works on RHEL 5.5 with sun jdk and EAP 5.0.1
Comment 3 Ian Springer 2010-06-22 16:16:14 EDT
I wasn't able to reproduce this, but I agree, it looks like a JBAS bug. I'll create a JBAS JIRA issue for it.
Comment 4 Ian Springer 2010-06-22 16:36:16 EDT
I've created https://jira.jboss.org/browse/JBPAPP-4514.
Comment 5 Corey Welton 2010-06-23 08:58:04 EDT
QA Closing - bug in JBAS, not rhq

Note You need to log in before you can comment on or make changes to this bug.