Bug 599011 - Can't change cursor theme
Can't change cursor theme
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 10:11 EDT by Garrett Mitchener
Modified: 2011-06-13 13:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 581173
Environment:
Last Closed: 2011-06-13 12:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2010-06-02 10:11:31 EDT
+++ This bug was initially created as a clone of Bug #581173 +++

On F13 I can't change the cursor theme. Nothing happens when I click a different one in appearance preferences.

--- Additional comment from mclasen@redhat.com on 2010-04-10 16:46:50 EDT ---

Is gnome-settings-daemon running in your session ?
Does 

ps ax | grep gnome-settings-daemon

report anything ?

--- Additional comment from web.cosas@gmail.com on 2010-04-10 18:09:31 EDT ---

It is running:

$ ps ax | grep gnome-settings-daemon
 2038 ?        Ss     0:02 /usr/libexec/gnome-settings-daemon
 2776 pts/0    S+     0:00 grep gnome-settings-daemon

--- Additional comment from just4nick@gmail.com on 2010-04-27 11:58:48 EDT ---

It doesn't work on KDE either. If you change the cursor theme in "System settings" nothing happen although Bluecurve theme is selected.
I've manually changed gtk-cursor-theme-name = "dmz-aa" to gtk-cursor-theme-name = "Bluecurve" in "/etc/gtk-2.0/gtkrc" and its OK now.

--- Additional comment from mclasen@redhat.com on 2010-04-30 10:47:24 EDT ---

I don't really have any good ideas for how to further debug this.

--- Additional comment from garrett.mitchener@gmail.com on 2010-05-28 13:35:21 EDT ---

Are you using compiz (=fancy 3d desktop effects) or metacity (=vanilla) as your window manager?

I'm having trouble with cursor theme too.  I like the mouse cursor to be large, and when I use metacity, setting the size seems to work.  But under compiz, half the time it's right and half the time it's wrong, depending on what part of the window you're pointing at.  Under metacity, changing the mouse theme and size works fine.

There's a related bug report here, which suggests it's bad patch applied to compiz:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/459647

--- Additional comment from web.cosas@gmail.com on 2010-05-28 13:55:00 EDT ---

Yes, I'm using compiz. My workaround (somehow suggested in the ubuntu bug report) was to simply rename the folders in /usr/share/icons so that the one containing the cursor theme I wanted (dmz white) is now named dmz, which if I'm not mistaken is the one that compiz is picking.

--- Additional comment from jfrieben@hotmail.com on 2010-05-31 06:55:21 EDT ---

I can confirm that this issue is related to compiz. As log as I ran metacity, the Bluecurve icon theme was used without any problem. Issue applies to
- compiz-0.8.6-1.fc13.x86_64


----------

Since we seem to agree that this is a compiz problem, I'm going to clone this over to the compiz bug list...
Comment 1 Joachim Frieben 2010-06-02 15:08:10 EDT
Is it a genuine feature of cloning a bug to make mail addresses appear in the body of the report? Now that bugzilla is searchable by Google certainly a bad idea ..
Comment 2 Garrett Mitchener 2010-11-05 14:28:31 EDT
In Fedora 14, all still seems to be the same.  Under compiz I see irregular cursor sizes: I set my mouse cursors to be as large as possible.  In firefox, I see correctly sized large cursors, but not on window decorations, the panel, panel menus, nautilus, ...

The mouse cursor is the correct size on everything under metacity.
Comment 3 DJ 2011-02-17 10:10:30 EST
I'd like to add that you also can't change the SIZE of your cursor. In my case, DMZ, since i'm stuck with it. Can't change theme and size. I remember this was due a bad patch applied in compiz, which was a wrong path pointing to mouse related .c file. In fact, the correct path seemed to be the ackward one, and the wrong path was the one which seemed corrected.
Comment 4 DJ 2011-02-17 10:19:37 EST
Here's the excerpt of the fix, in ubuntu. At the time I was using Lucid Lynx and it really fixed, perhaps Red Hat devs can fix this now.

===============================================================================

If you can't wait for this to be fixed upstream, here's a step-by-step guide of how to fix based on d.a.'s description (thanks d.a.!) for those not familiar with modifying and re-building things from source.

1. Make sure you have apt-src installed [sudo apt-get install apt-src].
2. Checkout the compiz-core source [sudo apt-src install compiz-core], this may take a while.
3. Find the relevant file, and modify it accordingly. [sudo vi compiz-0.8.4/debian/patches/013-add-cursor-theme-support.patch].
3a. Modify lines 133, 135 and 136 to change "core.xml.in" to "core.xml.in.in" and save.
4. Rebuild the package [sudo apt-src build compiz-core], this may take a while.
5. Install compiz-core over existing version [sudo sudo dpkg --install compiz-core_0.8.4-0ubuntu15_amd64.deb] (note I'm on 64-bit system, so filename may be different for you, but you should only need to replace the core one, not the others).
6. Refresh compiz. I just did Alt+F2 [metacity --replace], then Alt+F2 [compiz --replace].

..and you're done! Mouse cursor and size should now reflect what you have set in your preferences.

Massive thanks to d.a. for figuring all this out!

===========================================================================
Comment 5 Fedora Admin XMLRPC Client 2011-06-01 16:27:31 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-06-01 16:28:12 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-06-01 16:31:18 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-06-01 16:31:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 leigh scott 2011-06-13 12:40:53 EDT
This isn't compiz issue and I can't be bothered to reassign it.
Comment 10 leigh scott 2011-06-13 13:26:42 EDT
(In reply to comment #9)
> This isn't compiz issue and I can't be bothered to reassign it.

Just to clarify my stance, report this upstream as I have no intention to fix their bugs.

Note You need to log in before you can comment on or make changes to this bug.