Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 599015 - Use nc or netcat binary
Use nc or netcat binary
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 10:15 EDT by Lars Müller
Modified: 2010-06-02 12:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 11:34:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch src/virtManager/console.py to use nc or netcat from /usr/bin (1.20 KB, patch)
2010-06-02 10:27 EDT, Lars Müller
no flags Details | Diff
output of netcat -h (1.12 KB, text/plain)
2010-06-02 11:03 EDT, Lars Müller
no flags Details

  None (edit)
Description Lars Müller 2010-06-02 10:15:24 EDT
Make use of /usr/bin/nc or /usr/bin/netcat in virtManager/console.py
Comment 1 Lars Müller 2010-06-02 10:27:25 EDT
Created attachment 419050 [details]
Patch src/virtManager/console.py to use nc or netcat from /usr/bin
Comment 2 Cole Robinson 2010-06-02 10:45:17 EDT
That code is typically run on a remote system, so doing a local bin check is not valid. What exactly are you trying to accomplish, use netcat if nc doesn't exist? Is suse's nc named netcat? What's the output of netcat -h
Comment 3 Lars Müller 2010-06-02 10:54:45 EDT
I tried to adopt the patch suggested by Andreas in 2009.

See http://www.redhat.com/archives/et-mgmt-tools/2009-January/msg00072.html

You're right.  The goal is to use netcat if nc doesn't exist.

The patch in its unconditional version is part of the Virtualization:virt-manager project of the openSUSE Build Service.  See http://download.opensuse.org/repositories/Virtualization/
Comment 4 Cole Robinson 2010-06-02 10:59:54 EDT
Can you provide the output of netcat -h on your machine? Does libvirt carry a similar patch to s/nc/netcat/g or something?
Comment 5 Lars Müller 2010-06-02 11:03:58 EDT
Created attachment 419061 [details]
output of netcat -h
Comment 6 Lars Müller 2010-06-02 11:12:00 EDT
libvirt includes a patch to use netcat (if available) or socat.

Looks like I've to find a way to check if we have the binary on the other side of the connection.
Comment 7 Lars Müller 2010-06-02 11:34:18 EDT
/usr/bin/nc is available from the netcat-openbsd package.  Sorry for all the stupid noise.

The SUSE virt-manager package should use this binary and no more patch is required.
Comment 8 Cole Robinson 2010-06-02 11:41:29 EDT
Probably a good idea to have your libvirt add a dep on that package.
Comment 9 Lars Müller 2010-06-02 12:08:41 EDT
Yes.  I filed https://bugzilla.novell.com/show_bug.cgi?id=611023 to track this on the SUSE side.

Note You need to log in before you can comment on or make changes to this bug.