This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 599089 - qemu-kvm stuck after system_reset when using "-kernel -initrd" option
qemu-kvm stuck after system_reset when using "-kernel -initrd" option
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-06-02 12:28 EDT by lihuang
Modified: 2013-01-09 06:35 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-29 16:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lihuang 2010-06-02 12:28:18 EDT
Description of problem:
found following message from dmesg,if do system_reset after start guest with " -kernel -initrd" commond line.

printk: 1159723 messages suppressed.
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
emulation failed (pagetable) rip e22 66 ea 00 10
printk: 2089716 messages suppressed.
emulation failed (pagetable) rip e22 66 ea 00 10
printk: 2085769 messages suppressed.
emulation failed (pagetable) rip e22 66 ea 00 10
printk: 2083581 messages suppressed.
emulation failed (pagetable) rip e22 66 ea 00 10

Tasks: 1204 total,   1 running, 1203 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.1%us,  1.2%sy,  0.0%ni, 98.5%id,  0.3%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  1054284312k total,  8855836k used, 1045428476k free,   144336k buffers
Swap:  5484536k total,        0k used,  5484536k free,  7700128k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
 6148 root      15   0 8496m 204m 3960 S 100.1  0.0   5:13.77 qemu-kvm          


Version-Release number of selected component (if applicable):
[root@dhcp-66-83-236 tmp]# rpm -q kvm
kvm-83-164.el5_5.10
[root@dhcp-66-83-236 tmp]# rpm -q kernel
kernel-2.6.18-194.3.1.el5
[root@dhcp-66-83-236 tmp]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 5.5-2.2 (3)


How reproducible:
100%

Steps to Reproduce:
1.
/usr/libexec/qemu-kvm -M rhel5.4.0 -m 8G -smp 8 -name kernel -uuid 79cdf792-066e-4c4b-b8ba-987a6e031ea5 -no-kvm-pit-reinjection -monitor stdio -boot c -kernel rhel5.5/vmlinuz -initrd rhel5.5/initrd.img -append method=http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.5-Server-20100322.0/tree-x86_64/ clocksource=apci_pm -drive file=lihuang.qcow2,if=ide -net nic -net tap -usb -vnc :1
2.
(qemu) system_reset 

3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Tomas Von Veschler 2010-08-01 10:50:29 EDT
I able to reproduce this trying to run RHEL6 Live from pxe (https://fedorahosted.org/cobbler/wiki/HowToPxeAnyLiveCd).

Host RHEL5.5:
kvm-83-164.el5_5.12
kernel-2.6.18-194.8.1.el5

99% cpu of qemu-kvm

Aug  1 16:42:10 tvvc kernel: printk: 2034096 messages suppressed.
Aug  1 16:42:10 tvvc kernel: emulation failed (pagetable) rip 5c5c 0f fd a6 b6
Aug  1 16:42:15 tvvc kernel: printk: 2036286 messages suppressed.
Aug  1 16:42:15 tvvc kernel: emulation failed (pagetable) rip 5c5c 0f fd a6 b6

/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -startdate 2010-08-01T16:21:50 -name foo -smp 1,cores=1 -k en-us -m 256 -boot n -net nic,vlan=1,macaddr=00:1a:4a:1f:10:02,model=virtio -net tap,vlan=1,ifname=virtio_10_1,script=no -drive file=/rhev/data-center/8b6e25ff-c44d-48cb-ab96-c92f70a2d199/e0dd8d3e-c484-4d8f-bcf6-475d1a8339eb/images/eddd286d-138d-4a84-a493-53a2de3651d2/c50f20cc-3643-4101-8a0f-67575eb15b37,media=disk,if=virtio,cache=off,serial=84-a493-53a2de3651d2,boot=on,format=raw,werror=stop -pidfile /var/vdsm/68cfe8d5-1586-4d41-9f67-0db2bb213f24.pid -soundhw ac97 -spice sslpassword=,sslciphersuite=DEFAULT,sslcert=/var/vdsm/ts/certs/vdsmcert.pem,sslkey=/var/vdsm/ts/keys/vdsmkey.pem,ssldhfile=/var/vdsm/ts/keys/dh.pem,sslcafile=/var/vdsm/ts/certs/cacert.pem,host=0,secure-channels=main+inputs,ic=on,sport=5890,port=5910 -qxl 1 -cpu qemu64,+sse2,+cx16,+ssse3,+sse4.1 -M rhel5.5.0 -notify all -balloon none -smbios type=1,manufacturer=Red Hat,product=RHEL,version=5Server-5.5.0.2,serial=89BEE381-4A32-11CB-9AEB-BD871C15AD65_00:22:68:0b:c7:7e,uuid=68cfe8d5-1586-4d41-9f67-0db2bb213f24 -vmchannel di:0200,unix:/var/vdsm/68cfe8d5-1586-4d41-9f67-0db2bb213f24.guest.socket,server -monitor unix:/var/vdsm/68cfe8d5-1586-4d41-9f67-0db2bb213f24.monitor.socket,server
Comment 3 Eduardo Habkost 2010-10-15 10:54:32 EDT
I have tried to reproduce the bug on two machines: one with Intel CPU, another with AMD CPU. No sucess.

Marcelo, Avi, do you have any clue on what could cause emulation failed errors like above?
Comment 4 Avi Kivity 2010-10-17 06:00:11 EDT
No idea here.

Try checking how -kernel and -initrd behave on reset.  If we want the kernel to re-execute, they should be re-copied to system memory.  If we want the normal boot process, they shouldn't.  Not even sure what we want here.

In any case, -kernel is not a good idea for production scenarios.
Comment 7 RHEL Product and Program Management 2011-01-11 15:45:12 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 17:51:57 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 Shaolong Hu 2011-01-28 05:07:19 EST
Reproduce on kvm-83-224.el5/kernel2.6.18-237.el5
Host:  RHEL5.6-x86-64
Guest: RHEL5.5-x86-64

Steps:
1. Start guest with "-kernel -initrd" commond line.
2. During boot/installation: (qemu)system_reset


Actual Results:
1. Guest stuck after system_reset.
2. Qemu-kvm CPU usage 100%.
3. No abnormal dmesg message.

Note You need to log in before you can comment on or make changes to this bug.