Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 599119 - Anaconda fails on ext3 partitions mounted as ext4
Anaconda fails on ext3 partitions mounted as ext4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
: Reopened
: 634959 661733 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 13:38 EDT by Andrew John Hughes
Modified: 2011-10-17 15:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-17 15:45:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Crash Dump (376.37 KB, application/octet-stream)
2010-06-02 13:38 EDT, Andrew John Hughes
no flags Details

  None (edit)
Description Andrew John Hughes 2010-06-02 13:38:36 EDT
Created attachment 419109 [details]
Anaconda Crash Dump

Description of problem:

Anaconda crashes when it finds an ext3 partition mounted using the ext4 driver:

Exception: fstab entry /dev/unbreakable/root is malformed: scanned format (ext3) differs from fstab format (ext4)

However, doing so is valid and allows ext3 partitions to use ext4 performance improvements without breaking backwards compatibility:

https://ext4.wiki.kernel.org/index.php/Ext4_Howto#Converting_an_ext3_filesystem_to_ext4

Version-Release number of selected component (if applicable):

F13

How reproducible:

Run preupgrade on a setup where an ext3 partition is mounted using the ext4 driver in fstab

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Log from anaconda attached.
Comment 1 Chris Lumens 2010-06-02 13:56:20 EDT

*** This bug has been marked as a duplicate of bug 577260 ***
Comment 2 Andrew John Hughes 2010-06-02 14:38:01 EDT
This isn't a duplicate.  The bug referred to seems to be a valid error caused by a broken fstab, whereas extX to extY is a valid configuration that should be supported (and was by previous preupgrades on the same system).
Comment 3 Chris Lumens 2010-06-02 15:00:18 EDT
It's essentially the same - your fstab is "broken" in that the contents of the fstab file do not match what's on the disk.
Comment 4 Andrew John Hughes 2010-06-02 15:53:24 EDT
The fstab is not broken.  Having ext3 partitions mounted as ext4 is perfectly valid and actually recommended to gain performance improvements: https://ext4.wiki.kernel.org/index.php/Ext4_Howto#Converting_an_ext3_filesystem_to_ext4

I've worked around it by reverting the partition to ext3, preupgrading and then changing it back to ext4.
Comment 5 Chris Lumens 2010-06-02 15:59:50 EDT
Notice my conveniently placed quotes.
Comment 6 Andrew John Hughes 2010-06-03 06:47:20 EDT
Yes, I got that.  What I want to know is what the plan is to fix this bug?
Comment 8 Bug Zapper 2010-07-30 07:47:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Chris Lumens 2010-09-22 13:44:30 EDT
*** Bug 634959 has been marked as a duplicate of this bug. ***
Comment 10 David Lehman 2010-12-09 11:35:00 EST
(In reply to comment #0)
> Anaconda crashes when it finds an ext3 partition mounted using the ext4 driver:
> 
> Exception: fstab entry /dev/unbreakable/root is malformed: scanned format
> (ext3) differs from fstab format (ext4)
> 
> However, doing so is valid and allows ext3 partitions to use ext4 performance
> improvements without breaking backwards compatibility:

The set of things that people can do to their systems that are considered to be valid from one perspective or another is truly massive, and we make no effort to support everything that can possibly be done.

You really need backwards compatibility with ext3 on your root filesystem? May I ask what for?
Comment 11 David Lehman 2010-12-09 11:38:58 EST
*** Bug 661733 has been marked as a duplicate of this bug. ***
Comment 12 Kenny Root 2011-04-19 05:07:32 EDT
I ran into this with a Fedora 14 installation where I believe it mounted /boot as ext4 by default. Upgrading to the Fedora 15 alpha fails with this error now.

Of course, changing /boot to be ext3 in /etc/fstab gets past it, but it will probably halt your average user in their tracks.
Comment 13 David Lehman 2011-10-17 15:45:33 EDT
This will be possible without error in Fedora 16 (anaconda-16.21-1).

Note You need to log in before you can comment on or make changes to this bug.