Bug 599125 - SELinux is preventing /usr/libexec/gdm-session-worker "create" access on .xsession-errors.
SELinux is preventing /usr/libexec/gdm-session-worker "create" access on...
Status: CLOSED DUPLICATE of bug 543970
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:be112e0c140...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 13:45 EDT by Chris Miller
Modified: 2010-06-02 14:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 14:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Miller 2010-06-02 13:45:50 EDT
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "create" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.30.2-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686 #1 SMP
                              Thu May 13 05:55:24 UTC 2010 i686 i686
Alert Count                   8
First Seen                    Sun 30 May 2010 02:54:29 PM PDT
Last Seen                     Sun 30 May 2010 04:35:08 PM PDT
Local ID                      9d961d60-5c30-4e13-9c9b-677188491747
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275262508.960:1159): avc:  denied  { create } for  pid=27044 comm="gdm-session-wor" name=".xsession-errors" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1275262508.960:1159): avc:  denied  { open } for  pid=27044 comm="gdm-session-wor" name=".xsession-errors" dev=sda2 ino=10878991 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275262508.960:1159): arch=40000003 syscall=5 success=yes exit=12 a0=996d9a0 a1=442 a2=180 a3=996d9a0 items=0 ppid=27012 pid=27044 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=177 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,admin_home_t,file,create
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file { create open };
Comment 1 Daniel Walsh 2010-06-02 14:05:54 EDT

*** This bug has been marked as a duplicate of bug 543970 ***

Note You need to log in before you can comment on or make changes to this bug.