Bug 599133 - Cannot set an alarm on meeting invitations
Summary: Cannot set an alarm on meeting invitations
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 12
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-02 18:02 UTC by Trevin Beattie
Modified: 2010-06-25 07:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 08:26:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 598594 None None None Never

Description Trevin Beattie 2010-06-02 18:02:54 UTC
Description of problem:
I am unable to set or change the alarm for meetings to which I am invited.  When I open the appointment in Calendar, it says "Event cannot be fully edited, because you are not the organizer" and the alarm and save buttons are disabled.  This causes me to miss meetings when the organizer neglects to add an alarm to the invitation.

Both MS Outlook and my previous version of evolution (2.12) allowed me to change the alarm.  Both mail agents set the default alarm for all received meetings according to my user preferences if there was no alarm in the invite.  Evolution 2.12 also allowed me to edit the meeting with just a warning: "Changes made to this item may be discarded if an update arrives", and MS Outlook lets me edit the meeting with no complaint.

Version-Release number of selected component (if applicable):
evolution-2.28.3-1.fc12.i686
evolution-data-server-2.28.3-2.fc12.i686

How reproducible:
All invites from others.

Steps to Reproduce:
1. Have somebody send you a meeting invitation without an alarm.
2. Accept the invitation.
3. Open the meeting in your calendar.
  
Actual results:
The meeting has no alarm, and the alarm button is disabled.

Expected results:
The meeting has my default alarm set, and I should be able to edit the alarm time.

Additional info:
It doesn't matter whether I've posted the meeting to my local calendar or my Exchange calendar.

Comment 1 Milan Crha 2010-06-03 08:26:59 UTC
Thanks for a bug report. I didn't know that 2.12 was able to modify meetings organized by someone else. Anyway, there is an upstream bug report about the same, thus I'm moving this one there. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=598594

Comment 2 Trevin Beattie 2010-06-07 18:23:03 UTC
It looks like the fix was committed to the gnome-2-28 branch three weeks ago, but it's up to the distros to pick it up.

https://bugzilla.gnome.org/show_bug.cgi?id=594153

Comment 3 Trevin Beattie 2010-06-23 15:44:49 UTC
By the way, it appears that the incoming meeting invites DO have an alarm, but Evolution is ignoring it.  I found this in the raw ICS attachment of a meeting I just accepted:

BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:REMINDER
TRIGGER;RELATED=START:-PT00H15M00S
END:VALARM

but in my calendar, the meeting has no alarm.

This may be a separate bug from the one Gnome addressed in 594153.

(By the way, can I expect a new update to evolution-2.28.3 any time soon?)

Comment 4 Milan Crha 2010-06-24 06:44:23 UTC
(In reply to comment #3)
> By the way, it appears that the incoming meeting invites DO have an alarm, but
> Evolution is ignoring it.  I found this in the raw ICS attachment of a meeting
> I just accepted:
> but in my calendar, the meeting has no alarm.

Alarms are stripped on the acceptance, unless you indicate you want to inherit them (there is a chekbox above the confirmation buttons). It's probably available since 2.30.0, I'm not sure.

> This may be a separate bug from the one Gnome addressed in 594153.
> 
> (By the way, can I expect a new update to evolution-2.28.3 any time soon?)    

Unfortunately not, there is not planed any update for 2.28.x, the actual stable is 2.30.x.

Comment 5 Trevin Beattie 2010-06-24 15:48:16 UTC
Personally I don't care if the next build is 2.28.4 or 2.30.2, so long as I can update it in Fedora 12.

Is the checkbox you mentioned the one labeled "Inherit reminder"?  That wasn't obvious.  I would prefer that setting an alarm (whether from the meeting request or Evolution's user preferences) be enabled by default, especially since I am unable to change the alarm.

Comment 6 Milan Crha 2010-06-25 07:17:14 UTC
(In reply to comment #5)
> Is the checkbox you mentioned the one labeled "Inherit reminder"?

Yes, that's it. But I believe after change in the upstream bug there is not much need to depend on organizer's preference for alarms.


Note You need to log in before you can comment on or make changes to this bug.