Bug 599144 - RFE: Please consider branch to EPEL.
RFE: Please consider branch to EPEL.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: classads (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 14:24 EDT by Steve Traylen
Modified: 2010-06-30 10:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: classads-1.0.8-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 10:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bumps so to 1.0.0 (671 bytes, patch)
2010-06-07 17:25 EDT, Steve Traylen
no flags Details | Diff
Patch to .spec using .so patch and updating to 1.0.7. (1.52 KB, patch)
2010-06-07 17:28 EDT, Steve Traylen
no flags Details | Diff

  None (edit)
Description Steve Traylen 2010-06-02 14:24:52 EDT
I'd be interested in seeing classads available within EPEL, is this
something you are willing
 to do.

 I tested just on CentOS 5 with your devel package and builds just
fine with no modification.

I'm an EPEL packager so can proceed if needs be.
Comment 1 Lee Mitchell 2010-06-04 16:41:51 EDT
Steve, fyi, at condor week 2010 (April 2010), I spoke with Matt (matt at redhat.com) about this along with the request to put condor in EPEL ( #569598).  Matt said, yes, he would grant permission for both condor and classads to go into EPEL, but he would like to be listed as a co-maintainer of both condor and classads in EPEL in case he ever needs to fix something.

Would you also be interested in maintaining condor in EPEL?  If so, please do.  (I think you are, since you are working on getting classads into EPEL.)
Comment 2 Matthew Farrellee 2010-06-05 10:15:18 EDT
Lee is spot on.

BZ569598 is the RFE for condor.
Comment 3 Steve Traylen 2010-06-07 13:28:38 EDT
Hi Matt,

 Okay I'll go ahead and request the classads branch for EPEL and
 make you a co-maintainer which I'm more than happy for you to be.

 I see no reason not to start with the 1.0.7 release, between 1.0.4 as
 you have and 1.0.7 it looks to be bug fixes and given EPEL should
 be more conservative it's good to start high.

 http://www.cs.wisc.edu/condor/classad/c++changelogs/changes-1.0.7.txt

Steve.
Comment 4 Matthew Farrellee 2010-06-07 13:43:27 EDT
One thing to be careful about with classads is the ABI is not properly versioned, which makes going high attractive. However, there shouldn't be anything interesting in 1.0.7 that isn't already in the current version (1.0.6). That said, if you have ideas on how to adjust the .so to avoid difficult to debug ABI issues I'd be happy to spin up a 1.0.7.
Comment 5 Steve Traylen 2010-06-07 17:25:39 EDT
Created attachment 421952 [details]
Bumps so to 1.0.0

A patch to Makefile.am.m4 to set the .so version to 1.0.0. Is this what
you meant?
Comment 6 Steve Traylen 2010-06-07 17:28:08 EDT
Created attachment 421953 [details]
Patch to .spec using .so patch and updating to 1.0.7.

Here's the corresponding .spec file as well also updating to 1.0.7.
Comment 7 Matthew Farrellee 2010-06-10 09:30:09 EDT
classads 1.0.8, which includes your suggestions, has been built for F14
Comment 8 Fedora Update System 2010-06-11 02:13:50 EDT
classads-1.0.8-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/classads-1.0.8-1.el4
Comment 9 Fedora Update System 2010-06-11 02:14:02 EDT
classads-1.0.8-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/classads-1.0.8-1.el5
Comment 10 Fedora Update System 2010-06-11 19:36:56 EDT
classads-1.0.8-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update classads'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/classads-1.0.8-1.el4
Comment 11 Fedora Update System 2010-06-11 19:37:51 EDT
classads-1.0.8-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update classads'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/classads-1.0.8-1.el5
Comment 12 Fedora Update System 2010-06-30 10:23:42 EDT
classads-1.0.8-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-06-30 10:26:41 EDT
classads-1.0.8-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.