Bug 59920 - "rpmfind --latest" gets currently installed version
Summary: "rpmfind --latest" gets currently installed version
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmfind   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-14 22:16 UTC by Don Vanco
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-14 22:17:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Don Vanco 2002-02-14 22:16:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
When using rpmfind to pull the "latest" release of a package it appears to NOT 
check what is installed currently and many times returns the package that's 
already installed.  Behavior on older releases would either a) return a newer 
package or b) tell you that your system is currently on the latest release of 
that package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Here's an example:
[root@DL320 root]# rpm -q openssl
openssl-0.9.6b-8
[root@DL320 root]# rpmfind openssl --latest
Non qualified hostname: DL320(none)
Installing openssl will require 2993 KBytes
### To Transfer:
ftp://ftp.redhat.com/pub/redhat/linux/7.2/en/os/i386/RedHat/RPMS//openssl-
0.9.6b-8.i386.rpm
Do you want to download these files to /tmp [Y/n/a/i] ? :


Actual Results:  It will, in fact, pull the package that's already on the system

Expected Results:  Information that I either have the latest package installed 
(and exit) or that newer one exists (and prompt for d/l)

Additional info:

Seems to be consistent across my 7.2 platforms

Comment 1 Daniel Veillard 2002-08-29 09:50:24 UTC
Maintainance of the rpmfind, RDF based database was turning
into a nightmare, the command line rpmfind tool is not supported 
anymore (I maintain rpmfind.net and can't keep track anymore),
I suggest Red Hat users use up2date to keep their systems up-to-date,

  sorry about that,

Daniel



Note You need to log in before you can comment on or make changes to this bug.