Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599201 - 32bit apps no longer work
32bit apps no longer work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 16:25 EDT by The Source
Modified: 2010-06-02 17:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 17:30:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2010-06-02 16:25:57 EDT
Description of problem:
32 bit windows apps no longer work in 1.2.rc2 though wine-wow.i686 is installed.
wine myapp.exe gives:
Trying to load PE image for unsupported architecture (I386)
Trying to load PE image for unsupported architecture (I386)
wine: Bad EXE format for Z:\mnt\d\myapp.exe

Version-Release number of selected component (if applicable):
wine-wow-1.2.0-0.2.rc2.fc13.x86_64
wine-wow-1.2.0-0.2.rc2.fc13.i686

wine32 command is no longer available

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andreas Bierfert 2010-06-02 17:30:56 EDT
rpm -q wine.x86_64 --conflicts
wine-wow(x86-32) = 1.2.0-0.2.rc2.fc13

Please either use the wine meta package (or at least take a look at how things are supposed to work) or know what you are doing...

* Mon May 24 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.2-0.1.rc1
[...]
- desktop package requires wine x86-32 because of wine/wine64 rename
[...]

Note You need to log in before you can comment on or make changes to this bug.