Bug 59928 - file conflict in xscreensaver-4.00-1
Summary: file conflict in xscreensaver-4.00-1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 63595 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-15 02:23 UTC by Jonathan Kamens
Modified: 2014-03-17 02:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-15 05:45:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-02-15 02:23:57 UTC
file /usr/share/control-center/Desktop/screensaver-properties.desktop from
install of xscreensaver-4.00-1 conflicts with file from package
control-center-1.4.0.1-23

Comment 1 Bill Nottingham 2002-03-28 09:04:00 UTC
Fixed in current rawhide, and will also be ffixed in future rawhides.

Comment 2 Kjetil T. Homme 2002-04-13 22:43:13 UTC
The problem is back.

file /usr/share/control-center/Desktop/screensaver-properties.desktop from
install of control-center-1.4.0.1-30 conflicts with file from package
xscreensaver-4.01-2

Comment 3 Bill Nottingham 2002-04-14 19:28:22 UTC
xscreensaver-4.01-2 is no longer in current rawhide...

Comment 4 Kjetil T. Homme 2002-04-14 20:15:01 UTC
Please don't be so oblique.  Do you mean there is a new version, or that
xscreensaver is gone altogether?  From the look of things, it's the latter.

# rpm -e xscreensaver
error: removing these packages would break dependencies:
        xscreensaver >= 4.01 is needed by control-center-1.4.0.1-25

I guess I need to remove the package and install new control-center in one
RPM-operation.  How do I do that?  I could make a dummy package with higher
version number containing no files to get rid of the conflict, but it's a bit
awkward.

(Is this a case where deb is superior?  A deb would say that control-center
replaces xscreensaver.  Can RPM do that?)

Comment 5 Jonathan Kamens 2002-04-15 01:14:52 UTC
He means just what he said.  The RPM about which you're reporting a problem,
xscreensaver-4.01-2, is no longer the current xscreensaver version in Raw Hide. 
It wasn't removed, it was downgraded.  The current Raw Hide xscreensaver version
is 3.33-4, which (I think) doesn't have this problem.


Comment 6 Kjetil T. Homme 2002-04-15 08:05:19 UTC
Allright, so shouldn't epoch for xscreensaver 3.33-4 be bumped?  4.01-2 was part
of skipjack after all.

I did fix the problem with
# rpm --oldpackage -Uvh xscreensaver-3.33-4.i386.rpm 
control-center_1%3a1.4.0.1-30_i386.rpm 

(perhaps this exchange in Bugzilla is enough documentation :)


Comment 7 Jonathan Kamens 2002-04-16 00:49:49 UTC
The epoch doesn't need to be bumped because beta releases are caveat emptor,
don't try to install them on a production system, don't try to upgrade from them
after the final release comes out, etc.  Beta packages which never make it to a
production release "just didn't happen," as far as RH policies are concerned.


Comment 8 Bill Nottingham 2002-04-16 05:39:24 UTC
*** Bug 63595 has been marked as a duplicate of this bug. ***

Comment 9 Kjetil T. Homme 2002-05-03 01:57:08 UTC
xscreensaver-4.01-2 is in Raw Hide now as far as I can tell?
(with the file conflict)

Comment 10 Need Real Name 2002-05-13 02:42:38 UTC
file /usr/share/control-center/Desktop/screensaver-properties.desktop from
install of xscreensaver-4.01-2 conflicts with file from package
control-center-1.4.0.1-31



Note You need to log in before you can comment on or make changes to this bug.