Bug 59932 - rebuild fails when local texmf-root exists
Summary: rebuild fails when local texmf-root exists
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-15 03:56 UTC by Enrico Scholz
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 15:38:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-02-15 03:56:02 UTC
Description of Problem:

When trying to rebuild tetex as an user who has a local texmf-root under
~/texmf, the build fails at a sanity check, since tetex (or better latex2html)
uses kpsewhich to determine paths:

| Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.97346
| ...
| /usr/src/redhat/BUILD/teTeX-1.0/latex2html-2K.1beta
| creating cache ./config.cache
| ...
| checking for TeX include path... /home/ensc/texmf/tex/latex/html

Therefore, some files will be installed under ~/texmf/... and are missing in the
final file-list.


Simplest way to prevent this will be the unsetting of HOME:

|  %build
|  unset TEXINPUTS || :
|+ unset HOME || %

Comment 1 Tim Waugh 2002-02-22 14:43:16 UTC
Done in 1.0.7-42.  I used:
+ unset HOME || :

Thanks.


Note You need to log in before you can comment on or make changes to this bug.