Bug 599424 - /CoreOS/fuse run failed using new beaker, but can pass by rhts.
Summary: /CoreOS/fuse run failed using new beaker, but can pass by rhts.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
high
high vote
Target Milestone: ---
Assignee: Marian Csontos
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593365 626738
TreeView+ depends on / blocked
 
Reported: 2010-06-03 08:23 UTC by yanfu,wang
Modified: 2010-08-24 09:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 13:55:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description yanfu,wang 2010-06-03 08:23:31 UTC
Description of problem:
I've tried to run /CoreOS/fuse using new beaker but failed, which can pass in rhts.


How reproducible:
always

Steps to Reproduce:
1. kernel_workflow.py -S rhts.redhat.com -u yanwang@redhat.com -d RHEL6.0-Snapshot-5 -P kernel -t /CoreOS/fuse -w "FUSE Sanity Testing for RHEL6." >xxx.xml
2. bkr job-submit --convert xxx.xml

  
Actual results:
there are "  {"event": ["Event", "end", "5619b3e6-6e15-11df-9c51-00e081467136", {}, null, {"task_id": "48c32ace-6e15-11df-8f0f-00e081467136", "rc": 1}]}" shown in the web-ui.
the failed log shown:
Try to run 'mount -t fuse ./sshfs-fuse-2.2/sshfs#localhost:/root './MP1''... /bin/sh: ./sshfs-fuse-2.2/sshfs: Permission denied
Failed!

this is failed job link: https://beaker.engineering.redhat.com/jobs/1506

I select part of these testcase to re-run in beaker,pls refer to these below links:
https://beaker.engineering.redhat.com/jobs/1699, fail again

and these testcases can pass in rhts:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=161106


Expected results:
tese case can run 

Additional info:

Comment 1 Bill Peck 2010-06-03 20:51:02 UTC
Marian,

It looks like a yum issue to me.  The metadata gets out of sync and it suggests running yum metadata clean all.  Can we update the harness to do that?

Comment 2 Marian Csontos 2010-06-04 13:11:47 UTC
Thanks Bill, I will try it out.

Q: How often is the repo rebuilt? IIUC it does not happen instantly after adding/changing test as I had issues where I updated a test (w/o changing metadata) while job was running and it failed due to checksum mismatch.

Workaround: In the meantime, simple rerunning the tests should be OK.

Comment 3 Bill Peck 2010-06-14 12:54:52 UTC
The repo is rebuilt everytime someone uploads a new task.

Comment 4 Marian Csontos 2010-06-21 11:38:34 UTC
Fixed upstream.

Comment 5 Bill Peck 2010-07-01 12:59:23 UTC
ping - can this be closed?

Comment 6 Marian Csontos 2010-07-02 21:24:39 UTC
The yum part is fixed now but the test is still failing.

I noticed some of the tests are passing all right (especially some i386 and s390x), and there were also some tests failing on RHTS as well.

Yanfu, are these (RHTS vs. Beaker) really equivalent tests?

Comment 7 yanfu,wang 2010-07-05 03:03:57 UTC
(In reply to comment #6)
> The yum part is fixed now but the test is still failing.
> 
> I noticed some of the tests are passing all right (especially some i386 and
> s390x), and there were also some tests failing on RHTS as well.
> 
> Yanfu, are these (RHTS vs. Beaker) really equivalent tests?    


yes, I check the fuse testsuite in rhts and beaker, they are both use rh-tests-fuse-1.1-17.noarch.
now I'm re-testing again,let's check again when these jobs finish:
i386 arch:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=165424
beaker job: 6325

x86_64:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=165425
beaker job: 6326

Comment 8 yanfu,wang 2010-07-06 09:27:15 UTC
seems fuse test can done in beaker now by check these above jobs, except virt part which may separated for the problem.

Comment 9 Bill Peck 2010-07-06 13:55:36 UTC
please open a separate bug for the virt issue if its a real issue.

Thanks


Note You need to log in before you can comment on or make changes to this bug.