Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599435 - pkgs linking against avahi libs pull in and enable avahi server
pkgs linking against avahi libs pull in and enable avahi server
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: avahi (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Lennart Poettering
qe-baseos-daemons
:
Depends On: 483160
Blocks: 782183 840699
  Show dependency treegraph
 
Reported: 2010-06-03 04:44 EDT by Tim Waugh
Modified: 2015-01-14 10:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 483160
Environment:
Last Closed: 2013-02-21 04:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0368 normal SHIPPED_LIVE avahi bug fix update 2013-02-20 15:52:40 EST

  None (edit)
Description Tim Waugh 2010-06-03 04:44:45 EDT
Also affects Red Hat Enterprise Linux 6.

+++ This bug was initially created as a clone of Bug #483160 +++

Description of problem:
Updating from RHEL-5.2 to 5.3 installed and enabled avahi (because of cups update - cups depends on avahi-compat-libdns_sd which depends on avahi)

Version-Release number of selected component (if applicable):
0.6.16-1.el5

How reproducible:
always

Steps to Reproduce:
1."yum update" on RHEL-5.2 system that does not have avahi installed.
2. reboot
3.
  
Actual results:
avahi is installed and running after reboot to new kernel

Expected results:
avahi should not be required by the compat libary rpm, avahi-compat-libdns_sd, and should not be installed because of dependency chains on systems where it is not installed

Additional info:
Automatic installation of daemons that open network ports and initiate broadcast traffic is a security significant event, and is unacceptable on enterprise servers.  I don't believe there's any reason avahi-compat-libdns_sd should require avahi, or if there is, avahi should not be configured to run by default.

--- Additional comment from lpoetter@redhat.com on 2009-12-17 13:48:07 EST ---

The reason why avahi-compat-libdns_sd requires avahi is because it links against the avahi libraries that are part of the avahi package.

The proper fix would be to split the avahi libraries off into a seperate package. That would be a non-trivial packaging change however, not sure if that is suitable for fastrack.

Splitting off the libraries is already being requested in bug 530087.
Comment 1 RHEL Product and Program Management 2010-06-03 04:55:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 RHEL Product and Program Management 2010-07-15 11:16:14 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 RHEL Product and Program Management 2011-04-03 22:03:57 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Suzanne Yeghiayan 2012-03-21 16:17:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 7 RHEL Product and Program Management 2012-07-10 03:22:29 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2012-07-10 19:05:37 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 15 errata-xmlrpc 2013-02-21 04:49:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0368.html

Note You need to log in before you can comment on or make changes to this bug.