Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599457 - Net Installer Crashed After Retrieving install.img
Net Installer Crashed After Retrieving install.img
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 05:52 EDT by roshnic
Modified: 2010-08-09 15:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 612232 (view as bug list)
Environment:
Last Closed: 2010-08-09 15:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of tty3 (38.84 KB, image/png)
2010-06-04 00:57 EDT, roshnic
no flags Details
screenshot of tty4 (52.33 KB, image/png)
2010-06-04 00:58 EDT, roshnic
no flags Details

  None (edit)
Description roshnic 2010-06-03 05:52:55 EDT
Description of problem:


Version-Release number of selected component (if applicable): 13.42


How reproducible:


Steps to Reproduce:
1. create a new grub entry with vmlinuz and initrd.img from an install disk
2. reboot and select above entry as boot option
3. select "url" among install-source options
4. configure ethernet interface
5. specify url for obtaining install.img

installer crashes after retrieving install.img  


Additional info:
Seen at prompt on crash:

Loader exited unexpectedly! Backtrace:
/sbin/loader[0x804f19e]
/sbin/loader[0x804f254]
/lib/libc.so.6(exit+0xdf)[0xccc48f]
/sbin/loader[0x8058114]
/sbin/loader[0x80527d9]
/lib/libc.so.6(__libc_start_main+0xe6)[0xcb4c6]
/sbin/loader[0x804cee1]
Running anaconda 13.42, the Fedora system installer - please wait.
exec of anaconda failed: Exec format error
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.
Comment 1 Chris Lumens 2010-06-03 09:23:59 EDT
The important frames...

0x8058114 - /usr/src/debug/anaconda-13.42/loader/selinux.c:47
0x80527d9 - /usr/src/debug/anaconda-13.42/loader/loader.c:2142
Comment 2 Chris Lumens 2010-06-03 09:53:05 EDT
42     if (!(pid = fork())) {
43         setenv("LD_LIBRARY_PATH", LIBPATH, 1);
44         execl("/sbin/load_policy",
45               "/sbin/load_policy", "-q", NULL);
46         logMessage(ERROR, "exec of load_policy failed: %m");
47         exit(1);
48     }

This is a pretty strange place to get a crash, but it seems obvious what the problem is - load_policy failed.  When you get this crash, can you jump over to tty3 and tty4, take a picture, and attach them to this bug report?
Comment 3 roshnic 2010-06-04 00:57:50 EDT
Created attachment 421115 [details]
screenshot of tty3
Comment 4 roshnic 2010-06-04 00:58:27 EDT
Created attachment 421116 [details]
screenshot of tty4
Comment 5 Chris Lumens 2010-08-09 15:45:15 EDT
Are you perhaps trying to install an x86_64 distribution on an i386 machine?  I've been completely unable to reproduce this problem in any installations here, and we have not gotten widespread reports of it.  So I don't know what could be going on.

Note You need to log in before you can comment on or make changes to this bug.