Bug 59951 - Imap creates bad timezone
Imap creates bad timezone
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 13:31 EST by Paul Moore
Modified: 2016-11-24 10:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-22 22:23:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Moore 2002-02-15 13:31:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
/usr/sbin/imapd creates bad unix mailbox From line due to bad timezone 
information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Send self mail from a foreign account.
2. Collect mail using pop on an Outlook or Outlook Express client.
3. Move message to a folder on an imap server.
	

Actual Results:  Message will appear to be received at the current time in GMT, 
which is then converted to an equivalent local time.


Expected Results:  Message should appear to be received at the current time in 
the current local timezone.


Additional info:

The following line in mailbox files on the imap server is responsible for the 
mistake:
From username@your.imap.server.com Wed Feb 13 17:07:51 2002 -0000
in my case this should be:
From username@your.imap.server.com Wed Feb 13 17:07:51 2002 +1000

This bug is documented in /usr/share/doc/imap-2000c/bugs.txt dated
Jan 10, 2001 from imap RPM is: imap-2000c-15.i386.rpm

"In some versions of Redhat Linux, SVR4-style timezone name lookup
doesn't work properly due to a bug in glibc.  The workaround is to
edit os_lnx.c to include tz_bsd.c instead of tz_sv4.c.  Note that
other versions of Linux don't support BSD-style timezone name
lookup, so don't make this change unless it's needed on your system."

The problem appears on both Outlook 2000 SR-1 (9.0.0.5414) and
Outlook Express 5.50.4807.1700 clients.

The problem appears on both imap and imaps implementations.
Comment 1 Paul Moore 2002-02-15 14:32:51 EST
Following instructions in /usr/share/doc/imap-2000c/bugs.txt as documented:

Application of /usr/src/redhat/SOURCES/imap-2000c-redhat-timezone.patch
-rw-r--r-- 1 root root 297 Feb 16 05:08 imap-2000c-redhat-timezone.patch
==========start=========
--- imap-2000c/src/osdep/unix/os_lnx.c.redhat-timezone  Wed Oct 25 09:41:08 2000
+++ imap-2000c/src/osdep/unix/os_lnx.c  Sat Feb 16 05:08:30 2002
@@ -42,4 +42,5 @@
 #define fork vfork
 #include "tcp_unix.c"
 #include "gr_waitp.c"
-#include "tz_sv4.c"
+/* #include "tz_sv4.c" */
+#include "tz_bsd.c"
============end===========

... does NOT result in any noticable change in behaviour as far as correct
timezone stamping of unix mailbox From lines is concerned. :(

Problem persists.
Comment 2 Mike A. Harris 2002-02-21 22:33:40 EST
If this is indeed a bug in glibc, then it is probably something that
should be fixed in glibc I think.  I have no idea either way, but
patching imap to fix a glibc bug doesn't seem right to me.

Reassigning to glibc component.
Comment 3 Jakub Jelinek 2002-04-05 04:05:42 EST
Should be fixed in glibc-2.2.4-24.

Note You need to log in before you can comment on or make changes to this bug.