Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599548 - [RFE] librgmanager
[RFE] librgmanager
Status: CLOSED DUPLICATE of bug 629384
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 09:46 EDT by Lon Hohberger
Modified: 2010-09-30 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-30 16:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2010-06-03 09:46:35 EDT
Description of problem:

There is no library for altering service states, checking service states, etc.  This is required in order for other management interfaces to interface with rgmanager directly instead of having to use clustat/clusvcadm.

Modelling should follow the cman API; maybe something like:

rgm_handle_t h = rgm_init();

int rgm_get_service_count(rgm_handle_t h);

typedef struct rgm_service_state_t;

int ret = rgm_get_service_states(rgm_handle_t h, rgm_service_state_t *states, int nstates);

int event = rgm_poll(rgm_handle_t h, struct timeval *timeout);

#define RGM_DISPATCH_ONE 0x1
#define RGM_DISPATCH_ALL 0x2
#define RGM_DISPATCH_BLOCKING 0x4

int rgm_dispatch(rgm_handle_t h, int flags, rgm_callback_t callback_func);

Version-Release number of selected component (if applicable): All
Comment 1 Lon Hohberger 2010-09-30 16:11:58 EDT

*** This bug has been marked as a duplicate of bug 629384 ***

Note You need to log in before you can comment on or make changes to this bug.