Bug 59956 - S3 Trio3D strange mirroring effect with X
S3 Trio3D strange mirroring effect with X
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-02-15 17:03 EST by Don Smith
Modified: 2007-04-18 12:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-26 04:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
XFree86 config file (3.70 KB, text/plain)
2002-03-11 15:00 EST, Don Smith
no flags Details
XFree86 log file (25.94 KB, text/plain)
2002-03-11 15:00 EST, Don Smith
no flags Details

  None (edit)
Description Don Smith 2002-02-15 17:03:33 EST
Description of Problem:

Two machines with Trio3D video (IBM x240, Netfinity 7600) have a corrupted 
display when X is loaded - there is a weird mirroring effect on the right 
portion of the display.

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. Choose "S3 Trio3D" for X configuration during install
2. finish install and reboot
3. login and start X

Actual Results:
weird mirroring effect

Expected Results:
normal display

Additional Information:
Comment 1 Mike A. Harris 2002-03-11 01:03:05 EST
Please attach Xfree86 config file and log file using the link below.
Comment 2 Don Smith 2002-03-11 14:54:09 EST
I was questioning my sanity as I tried to reproduce this bug again today - I 
wasn't seeing it until I realized that I wasn't setting a framebuffer mode for 
the console this time around, which is something I was doing before. It appears 
that this problem only occurs when you boot in framebuffer mode (vga=xxx 

I will attach the config and log files shortly.
Comment 3 Don Smith 2002-03-11 15:00:20 EST
Created attachment 48185 [details]
XFree86 config file
Comment 4 Don Smith 2002-03-11 15:00:57 EST
Created attachment 48186 [details]
XFree86 log file
Comment 5 Wendy Hung 2002-03-27 11:35:09 EST
Not fixed in Beta3(skipjack).
Comment 6 Wendy Hung 2002-04-11 11:58:49 EDT
Not fixed in Hampton beta4 (skipjack2).
Comment 7 Mike A. Harris 2002-04-13 19:37:05 EDT
Did this hardware work in a previous release of RHL, and if so, what
version of XFree86?  3.3.6, or 4.x, and what version of 4.x?

Try option "noaccel" also.
Comment 8 Mike A. Harris 2002-04-13 19:38:20 EDT
Try Xconfigurator --preferxf3 as well if it hasn't been tried already.
Comment 9 Don Smith 2002-05-07 11:09:24 EDT
This problem doesn't exist with XFree86 3.3.6a (included with RH7.2)
Comment 10 Mike A. Harris 2002-05-07 15:11:09 EDT
Try option "noaccel" also.

Comment 11 Don Smith 2002-05-07 16:12:29 EDT
"noaccel" had no effect (except to make things slower ;)
Comment 12 Mike A. Harris 2002-06-21 23:20:54 EDT
Please try rebooting without using the framebuffer.  Then reconfigure
X with Xconfigurator and choosing the VESA generic driver. Does the
VESA driver work?  If not, please attach config+log from that session
as well.

Comment 13 Don Smith 2002-07-24 09:35:18 EDT
The VESA driver works just fine, whether or not I use the framebuffer console.
Comment 14 Mike A. Harris 2002-07-26 04:54:54 EDT
Removing block on this bug.  It was not set by Red Hat.  Whoever set the
block on this bug, please do not manipulate our bug block trackers, as
it interferes with our internal bug tracking.  It is also noticeable
to developers (but doesn't show to others).

This bug will be resolved shortly however anyway by defaulting this video
adaptor to the "vesa" driver which is reported working above.
Comment 15 Mike A. Harris 2002-07-26 05:42:40 EDT
Driver default changed to "vesa" in hwdata-0.35-1 in rawhide.
Comment 16 Mike A. Harris 2004-08-30 02:00:12 EDT
I have had a feature request to change the driver of this card
from "vesa" back to "s3virge" by 2 users in bug #125866, and will
be making the change in the next build of the hwdata package for
Fedora Core development.

Please test Fedora Core 3 test2 test release once it is released
in September, and confirm wether or not the new "s3virge" driver
works with your system now or not.  If the driver fails for you
still in our current sources in Fedora Core 3 test2, could you
please file a bug report in upstream X.Org bugzilla for this
driver, at:  http://bugs.freedesktop.org

The video card in both bug reports seems to be completely identical,
including subsystem/subvendor ID, so I am assuming the driver may
work properly for everyone now.

Thanks in advance.
Comment 17 Don Smith 2004-08-30 11:49:49 EDT
If I can find a old system here with that video chipset, I'll give it
a try.

Note You need to log in before you can comment on or make changes to this bug.