Bug 59957 - RFE: add DRAC2 driver into kernel
RFE: add DRAC2 driver into kernel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 17:36 EST by Matt Domsch
Modified: 2007-03-26 23:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 13:06:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2002-02-15 17:36:58 EST
Description of Problem:
Please merge the Dell Remote Assistant Card 2 (DRAC2) driver (rac.o) into the 
Hampton kernel.  If changes are required to make the code more pleasing, please 
submit patches back to AMI <andrewm@ami.com> and <subashk@ami.com>.  With the 
code released under the GPL, AMI is no longer very interested in maintaining 
the code, but they do wish to be made aware of any changes that others make to 
it.
Comment 1 Joshua Giles 2002-03-08 14:23:34 EST
Deferring till we can clear up issues with changing the driver source.  Will 
have an update by early next week.
Comment 2 Arjan van de Ven 2002-03-08 14:26:54 EST
I'm over halfway cleaning the gpl driver... but I need some time to finish it 
Also somehow my card died (or at least starts interfering with my megaraid)
since I updated the firmware; this doesn't help testing ;(
Comment 3 Joshua Giles 2002-03-12 14:15:43 EST
Arjan,

Upgrade the latest firmware to 2.4 A02 it's a the dell website..search for 
B9K26602.exe 

If that fails, I will get you in contact with the DRAC II engineer.

We will hopefully get you a Dell system soon for DRAC II testing...by the way 
what machine did you install the DRAC II on?
Comment 4 Arjan van de Ven 2002-03-12 14:19:13 EST
It was in a dual athlon (due to lack of dell kit locally) ;(
I'll try to get firmware 2.4 on it although I need to get the box booting for
that... will play with it soon.
Comment 5 Matt Domsch 2002-03-12 14:41:25 EST
Reopening having worked out concerns within Dell's OpenManage team.  We'd like 
to still see this in Hampton if at all possible, with early drops to see what 
is changed from the AMI-written driver.  Josh and Larry (lead engineer, DRAC2, 
for Dell) will be doing the in-house testing of this driver with Hampton beta 
drops.
Comment 6 Arjan van de Ven 2002-03-26 13:06:45 EST
Card moved to different slot and firmware jumper used to wipe the firmware: my
machine boots again ;)

Also fixed a few oopses in the driver so it at least seems to find the card now;
included in 2.4.18-0.9 and later (in rawhide)
Comment 7 Michael K. Johnson 2002-03-26 14:23:28 EST
Closing since it's in rawhide (open a new bug if there are bugs
in the driver that need to be dealt with now...)

Note You need to log in before you can comment on or make changes to this bug.