Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599578 - rhncfg: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
rhncfg: DeprecationWarning: the sha module is deprecated; use the hashlib mod...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space11
  Show dependency treegraph
 
Reported: 2010-06-03 10:28 EDT by Miroslav Suchý
Modified: 2010-08-19 04:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 04:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2010-06-03 10:28:42 EDT
Description of problem:
In rhel6:
$ rhncfg-client list
/usr/share/rhn/config_common/utils.py:17: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
Comment 1 Milan Zázrivec 2010-08-04 10:34:12 EDT
This has been already fixed in spacewalk.git master:
6c9624ab7ec3a9962030a755c86e0d1f3617d40b
Comment 2 Milan Zázrivec 2010-08-19 04:24:13 EDT
Spacewalk 1.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.