Bug 599598 - gdb complains about missing debuginfo package for 'filesystem'......
Summary: gdb complains about missing debuginfo package for 'filesystem'......
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-03 15:03 UTC by Tom London
Modified: 2010-08-06 16:47 UTC (History)
3 users (show)

Fixed In Version: gdb-7.1.90.20100806-7.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 16:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gzip of core file...... (332.50 KB, application/x-gzip)
2010-06-05 21:57 UTC, Tom London
no flags Details

Description Tom London 2010-06-03 15:03:25 UTC
Description of problem:
I see this:

Core was generated by `/usr/lib64/openoffice.org/basis3.2/program/../ure-link/bin/uno.bin --quiet --si'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fdd75ffde20 in cppu::OInterfaceIteratorHelper::OInterfaceIteratorHelper (this=0x7fdd67ffe510, rCont_=...)
    at /usr/src/debug/OOO320_m19/cppuhelper/source/interfacecontainer.cxx:117
117			((XInterface *)pData)->acquire();
Missing separate debuginfos, use: debuginfo-install filesystem-2.4.35-1.fc14.x86_64
(gdb)

Can that be right?

Version-Release number of selected component (if applicable):
gdb-7.1-24.fc13.x86_64

How reproducible:
Every time I run gdb with this core file

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jan Kratochvil 2010-06-05 21:00:41 UTC
If you do not provide the whole core file please post at least:
eu-unstrip -n --core=corefile
Thanks.

Comment 2 Tom London 2010-06-05 21:11:30 UTC
Core file is 55M.  Let me know if you want me to post it.

I didn't think the filesystem package needed a debuginfo package .....

Anyway, here is the output per request:

[root@tlondon X200]# eu-unstrip -n --core=core.6535 
0x400000+0x227000 8c9595101e52b754a11887867e613ab277d3e4e7@0x40024c /usr/lib64/openoffice.org/ure/bin/uno.bin /usr/lib/debug/usr/lib64/openoffice.org/ure/bin/uno.bin.debug [exe]
0x7ffffbbff000+0x1000 5ac6e51574d1809b287e5b6a246fe611614fa886@0x7ffffbbff2f8 . - linux-vdso.so.1
0x7fdd7668c000+0x3f7000 30c7f6a32a364393f1fdb7ee5e5467e0c7b8d354@0x7fdd766001a0 /usr/lib64/openoffice.org/ure/bin/../lib/libuno_sal.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_sal.so.3.debug libuno_sal.so.3
0x7fdd76488000+0x203000 1ae462b8ef2830c6d08af2ecae060b5d7822081b@0x7fdd764001a0 /usr/lib64/openoffice.org/ure/bin/../lib/libuno_salhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_salhelpergcc3.so.3.debug libuno_salhelpergcc3.so.3
0x7fdd7625c000+0x22c000 b4a2ecfc67360fa05a56ae2c3396f088ebc3522e@0x7fdd762001a0 /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppu.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppu.so.3.debug libuno_cppu.so.3
0x7fdd75fb9000+0x2a3000 cb33d51f26589c796be0165c259fe22aafffd9e6@0x7fdd75e001a0 /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppuhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppuhelpergcc3.so.3.debug libuno_cppuhelpergcc3.so.3
0x3dc2200000+0x352000 92893d68cc907a56f77ceeead40ad0bbe1604777@0x3dc22001a0 /usr/lib64/libxml2.so.2.7.7 /usr/lib/debug/usr/lib64/libxml2.so.2.7.7.debug libxml2.so.2
0x7fdd75c96000+0x307000 ade9f2fd76992580bb4823b0b282fd1ab4a70363@0x7fdd75c96210 /usr/lib64/libstdc++.so.6.0.13 /usr/lib/debug/usr/lib64/libstdc++.so.6.0.13.debug libstdc++.so.6
0x3db8600000+0x284000 44e618ef55de412a8571f073220a16ad91873ec8@0x3db8600248 /lib64/libm-2.12.90.so /usr/lib/debug/lib64/libm-2.12.90.so.debug libm.so.6
0x7fdd75a7f000+0x216000 82cfc0ea001558ed5b6db32158a45057793698b3@0x7fdd75a7f1a0 /lib64/libgcc_s-4.4.4-20100525.so.1 /usr/lib/debug/lib64/libgcc_s-4.4.4-20100525.so.1.debug libgcc_s.so.1
0x3db7600000+0x387000 75a67c529005ad4d09084e8eafb9066793e52087@0x3db7600280 /lib64/libc-2.12.90.so /usr/lib/debug/lib64/libc-2.12.90.so.debug libc.so.6
0x3dc3e00000+0x237000 cb8975c990a9e783c2289ef2114f486695364670@0x3dc3e00248 /lib64/libcrypt-2.12.90.so /usr/lib/debug/lib64/libcrypt-2.12.90.so.debug libcrypt.so.1
0x3db7e00000+0x204000 968a128a44fa7f76f95bf0ecd7800dba564a8bc4@0x3db7e00248 /lib64/libdl-2.12.90.so /usr/lib/debug/lib64/libdl-2.12.90.so.debug libdl.so.2
0x3db7a00000+0x21d000 6317b446423153db21a6716e4e145f29af08b007@0x3db7a00248 /lib64/libpthread-2.12.90.so /usr/lib/debug/lib64/libpthread-2.12.90.so.debug libpthread.so.0
0x3db8a00000+0x217000 718492d52719e84029901376962ff9620e7a3dbe@0x3db8a001a0 /lib64/libz.so.1.2.5 /usr/lib/debug/lib64/libz.so.1.2.5.debug libz.so.1
0x3db7200000+0x223000 44eb2c59530af2b2f755d7d114dfdef20eb756fb@0x3db72001d8 /lib64/ld-2.12.90.so /usr/lib/debug/lib64/ld-2.12.90.so.debug ld-linux-x86-64.so.2
0x7fdd7581e000+0x25f000 2175d1b113b9f8e339c15ea5840aa7bac7ceb624@0x7fdd758001a0 /lib64/libfreebl3.so /usr/lib/debug/lib64/libfreebl3.so.debug libfreebl3.so
0x7fdd6ec7d000+0x2ba000 946d84f27a998230a351e7b9adead888ed5f43d6@0x7fdd6ec001a0 /usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so.debug bootstrap.uno.so
0x7fdd6ea62000+0x21b000 a7ee31746ad44d4bfc84de31e123b725457fb583@0x7fdd6ea001a0 /usr/lib64/openoffice.org/ure/lib/libreg.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libreg.so.3.debug libreg.so.3
0x7fdd6e848000+0x21a000 07e41aa4d9dda1776934186e80360cc5498fbbf8@0x7fdd6e8001a0 /usr/lib64/openoffice.org/ure/lib/libstore.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libstore.so.3.debug libstore.so.3
0x7fdd6e639000+0x20f000 5edb603c705535d870e5bb816d01d790c8cb51e1@0x7fdd6e6001a0 /usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so.debug libgcc3_uno.so
0x7fdd6e3f1000+0x20d000 c95adf9e367e9547b158492b13bce3650e091ae5@0x7fdd6e3f1248 /lib64/libnss_files-2.12.90.so /usr/lib/debug/lib64/libnss_files-2.12.90.so.debug libnss_files.so.2
0x7fdd6d372000+0x20f000 07074e53e2d8d21f11273949ee9eb77a6cb564b5@0x7fdd6d2001a0 /usr/lib64/openoffice.org/ure/lib/acceptor.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/acceptor.uno.so.debug acceptor.uno.so
0x7fdd6d166000+0x20c000 c306165f738800c035d8c40e8c3dbd4acbeb5878@0x7fdd6d0001a0 /usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so.debug bridgefac.uno.so
0x7fdd6cf62000+0x204000 fe7d50b1d80b01c4424ade892e2062238f9de097@0x7fdd6ce001a0 /usr/lib64/openoffice.org/ure/lib/librmcxt.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/librmcxt.so.3.debug librmcxt.so.3
0x7fdd6cd58000+0x20a000 54cde82706f4a620d502d2e2aef13d0b4e13fccc@0x7fdd6cc001a0 /usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so.debug remotebridge.uno.so
0x7fdd6cb24000+0x224000 3c34a7256be7e0bdfc337a82f8b8621114d713ee@0x7fdd6ca001a0 /usr/lib64/openoffice.org/ure/lib/liburp_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/liburp_uno.so.debug liburp_uno.so
0x7fdd66908000+0x2f6000 326161c58ab13b63570b0cefb1c5b40e0b129a29@0x7fdd669081a0 /usr/lib64/openoffice.org3/program/../share/uno_packages/cache/uno_packages/TkbryU_/pdfimport.oxt/pdfimport.uno.so - pdfimport.uno.so
[root@tlondon X200]#

Comment 3 Jan Kratochvil 2010-06-05 21:27:17 UTC
I do not see why it would think filesystem debuginfo is needed.
The core file itself is welcome, thanks.
There are some BZ size limits but it seems you should cope with it well.

Comment 4 Tom London 2010-06-05 21:48:16 UTC
Damn.  20MB limit on "non-patch" attachments.

Let me look around on where to post this....

Comment 5 Tom London 2010-06-05 21:53:26 UTC
I'll attach 3 "splits" of the core file.

Can't remember where to post this and log a URL....

Comment 6 Jan Kratochvil 2010-06-05 21:56:49 UTC
Even after some xz -9e compression?

Comment 7 Tom London 2010-06-05 21:57:01 UTC
Created attachment 421500 [details]
Gzip of core file......

Gzip of core file.

Comment 8 Jan Kratochvil 2010-06-05 22:16:35 UTC
I cannot find which build-id or file corresponds to the filesystem rpm.
Could you try on your system:
rpm -qf /usr/lib64/openoffice.org/ure/bin/uno.bin /usr/lib/debug/usr/lib64/openoffice.org/ure/bin/uno.bin.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_sal.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_sal.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_salhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_salhelpergcc3.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppu.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppu.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppuhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppuhelpergcc3.so.3.debug /usr/lib64/libxml2.so.2.7.7 /usr/lib/debug/usr/lib64/libxml2.so.2.7.7.debug /usr/lib64/libstdc++.so.6.0.13 /usr/lib/debug/usr/lib64/libstdc++.so.6.0.13.debug /lib64/libm-2.12.90.so /usr/lib/debug/lib64/libm-2.12.90.so.debug /lib64/libgcc_s-4.4.4-20100525.so.1 /usr/lib/debug/lib64/libgcc_s-4.4.4-20100525.so.1.debug /lib64/libc-2.12.90.so /usr/lib/debug/lib64/libc-2.12.90.so.debug /lib64/libcrypt-2.12.90.so /usr/lib/debug/lib64/libcrypt-2.12.90.so.debug /lib64/libdl-2.12.90.so /usr/lib/debug/lib64/libdl-2.12.90.so.debug /lib64/libpthread-2.12.90.so /usr/lib/debug/lib64/libpthread-2.12.90.so.debug /lib64/libz.so.1.2.5 /usr/lib/debug/lib64/libz.so.1.2.5.debug /lib64/ld-2.12.90.so /usr/lib/debug/lib64/ld-2.12.90.so.debug /lib64/libfreebl3.so /usr/lib/debug/lib64/libfreebl3.so.debug /usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so.debug /usr/lib64/openoffice.org/ure/lib/libreg.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libreg.so.3.debug /usr/lib64/openoffice.org/ure/lib/libstore.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libstore.so.3.debug /usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so.debug /lib64/libnss_files-2.12.90.so /usr/lib/debug/lib64/libnss_files-2.12.90.so.debug /usr/lib64/openoffice.org/ure/lib/acceptor.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/acceptor.uno.so.debug /usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so.debug /usr/lib64/openoffice.org/ure/lib/librmcxt.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/librmcxt.so.3.debug /usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so.debug /usr/lib64/openoffice.org/ure/lib/liburp_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/liburp_uno.so.debug /usr/lib64/openoffice.org3/program/../share/uno_packages/cache/uno_packages/TkbryU_/pdfimport.oxt/pdfimport.uno.so /usr/lib/debug/.build-id/8c/9595101e52b754a11887867e613ab277d3e4e7{,.debug} /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886{,.debug} /usr/lib/debug/.build-id/30/c7f6a32a364393f1fdb7ee5e5467e0c7b8d354{,.debug} /usr/lib/debug/.build-id/1a/e462b8ef2830c6d08af2ecae060b5d7822081b{,.debug} /usr/lib/debug/.build-id/b4/a2ecfc67360fa05a56ae2c3396f088ebc3522e{,.debug} /usr/lib/debug/.build-id/cb/33d51f26589c796be0165c259fe22aafffd9e6{,.debug} /usr/lib/debug/.build-id/92/893d68cc907a56f77ceeead40ad0bbe1604777{,.debug} /usr/lib/debug/.build-id/ad/e9f2fd76992580bb4823b0b282fd1ab4a70363{,.debug} /usr/lib/debug/.build-id/44/e618ef55de412a8571f073220a16ad91873ec8{,.debug} /usr/lib/debug/.build-id/82/cfc0ea001558ed5b6db32158a45057793698b3{,.debug} /usr/lib/debug/.build-id/75/a67c529005ad4d09084e8eafb9066793e52087{,.debug} /usr/lib/debug/.build-id/cb/8975c990a9e783c2289ef2114f486695364670{,.debug} /usr/lib/debug/.build-id/96/8a128a44fa7f76f95bf0ecd7800dba564a8bc4{,.debug} /usr/lib/debug/.build-id/63/17b446423153db21a6716e4e145f29af08b007{,.debug} /usr/lib/debug/.build-id/71/8492d52719e84029901376962ff9620e7a3dbe{,.debug} /usr/lib/debug/.build-id/44/eb2c59530af2b2f755d7d114dfdef20eb756fb{,.debug} /usr/lib/debug/.build-id/21/75d1b113b9f8e339c15ea5840aa7bac7ceb624{,.debug} /usr/lib/debug/.build-id/94/6d84f27a998230a351e7b9adead888ed5f43d6{,.debug} /usr/lib/debug/.build-id/a7/ee31746ad44d4bfc84de31e123b725457fb583{,.debug} /usr/lib/debug/.build-id/07/e41aa4d9dda1776934186e80360cc5498fbbf8{,.debug} /usr/lib/debug/.build-id/5e/db603c705535d870e5bb816d01d790c8cb51e1{,.debug} /usr/lib/debug/.build-id/c9/5adf9e367e9547b158492b13bce3650e091ae5{,.debug} /usr/lib/debug/.build-id/07/074e53e2d8d21f11273949ee9eb77a6cb564b5{,.debug} /usr/lib/debug/.build-id/c3/06165f738800c035d8c40e8c3dbd4acbeb5878{,.debug} /usr/lib/debug/.build-id/fe/7d50b1d80b01c4424ade892e2062238f9de097{,.debug} /usr/lib/debug/.build-id/54/cde82706f4a620d502d2e2aef13d0b4e13fccc{,.debug} /usr/lib/debug/.build-id/3c/34a7256be7e0bdfc337a82f8b8621114d713ee{,.debug} /usr/lib/debug/.build-id/32/6161c58ab13b63570b0cefb1c5b40e0b129a29{,.debug}

If any of the printed output will be "filesystem" (and which of the listed files corresponds to it).

Comment 9 Tom London 2010-06-05 23:07:42 UTC
Sure.

For the record, I've updated openoffice.org to openoffice.org-core-3.2.1-19.7.fc14.x86_64 since filing this.  

You want/need me to downgrade? back to 3.2.1-19.7?

[root@tlondon tmp]# sh -x x
+ rpm -qf /usr/lib64/openoffice.org/ure/bin/uno.bin /usr/lib/debug/usr/lib64/openoffice.org/ure/bin/uno.bin.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_sal.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_sal.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_salhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_salhelpergcc3.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppu.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppu.so.3.debug /usr/lib64/openoffice.org/ure/bin/../lib/libuno_cppuhelpergcc3.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_cppuhelpergcc3.so.3.debug /usr/lib64/libxml2.so.2.7.7 /usr/lib/debug/usr/lib64/libxml2.so.2.7.7.debug /usr/lib64/libstdc++.so.6.0.13 /usr/lib/debug/usr/lib64/libstdc++.so.6.0.13.debug /lib64/libm-2.12.90.so /usr/lib/debug/lib64/libm-2.12.90.so.debug /lib64/libgcc_s-4.4.4-20100525.so.1 /usr/lib/debug/lib64/libgcc_s-4.4.4-20100525.so.1.debug /lib64/libc-2.12.90.so /usr/lib/debug/lib64/libc-2.12.90.so.debug /lib64/libcrypt-2.12.90.so /usr/lib/debug/lib64/libcrypt-2.12.90.so.debug /lib64/libdl-2.12.90.so /usr/lib/debug/lib64/libdl-2.12.90.so.debug /lib64/libpthread-2.12.90.so /usr/lib/debug/lib64/libpthread-2.12.90.so.debug /lib64/libz.so.1.2.5 /usr/lib/debug/lib64/libz.so.1.2.5.debug /lib64/ld-2.12.90.so /usr/lib/debug/lib64/ld-2.12.90.so.debug /lib64/libfreebl3.so /usr/lib/debug/lib64/libfreebl3.so.debug /usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bootstrap.uno.so.debug /usr/lib64/openoffice.org/ure/lib/libreg.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libreg.so.3.debug /usr/lib64/openoffice.org/ure/lib/libstore.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libstore.so.3.debug /usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libgcc3_uno.so.debug /lib64/libnss_files-2.12.90.so /usr/lib/debug/lib64/libnss_files-2.12.90.so.debug /usr/lib64/openoffice.org/ure/lib/acceptor.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/acceptor.uno.so.debug /usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/bridgefac.uno.so.debug /usr/lib64/openoffice.org/ure/lib/librmcxt.so.3 /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/librmcxt.so.3.debug /usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/remotebridge.uno.so.debug /usr/lib64/openoffice.org/ure/lib/liburp_uno.so /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/liburp_uno.so.debug /usr/lib64/openoffice.org3/program/../share/uno_packages/cache/uno_packages/TkbryU_/pdfimport.oxt/pdfimport.uno.so /usr/lib/debug/.build-id/8c/9595101e52b754a11887867e613ab277d3e4e7 /usr/lib/debug/.build-id/8c/9595101e52b754a11887867e613ab277d3e4e7.debug /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886 /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886.debug /usr/lib/debug/.build-id/30/c7f6a32a364393f1fdb7ee5e5467e0c7b8d354 /usr/lib/debug/.build-id/30/c7f6a32a364393f1fdb7ee5e5467e0c7b8d354.debug /usr/lib/debug/.build-id/1a/e462b8ef2830c6d08af2ecae060b5d7822081b /usr/lib/debug/.build-id/1a/e462b8ef2830c6d08af2ecae060b5d7822081b.debug /usr/lib/debug/.build-id/b4/a2ecfc67360fa05a56ae2c3396f088ebc3522e /usr/lib/debug/.build-id/b4/a2ecfc67360fa05a56ae2c3396f088ebc3522e.debug /usr/lib/debug/.build-id/cb/33d51f26589c796be0165c259fe22aafffd9e6 /usr/lib/debug/.build-id/cb/33d51f26589c796be0165c259fe22aafffd9e6.debug /usr/lib/debug/.build-id/92/893d68cc907a56f77ceeead40ad0bbe1604777 /usr/lib/debug/.build-id/92/893d68cc907a56f77ceeead40ad0bbe1604777.debug /usr/lib/debug/.build-id/ad/e9f2fd76992580bb4823b0b282fd1ab4a70363 /usr/lib/debug/.build-id/ad/e9f2fd76992580bb4823b0b282fd1ab4a70363.debug /usr/lib/debug/.build-id/44/e618ef55de412a8571f073220a16ad91873ec8 /usr/lib/debug/.build-id/44/e618ef55de412a8571f073220a16ad91873ec8.debug /usr/lib/debug/.build-id/82/cfc0ea001558ed5b6db32158a45057793698b3 /usr/lib/debug/.build-id/82/cfc0ea001558ed5b6db32158a45057793698b3.debug /usr/lib/debug/.build-id/75/a67c529005ad4d09084e8eafb9066793e52087 /usr/lib/debug/.build-id/75/a67c529005ad4d09084e8eafb9066793e52087.debug /usr/lib/debug/.build-id/cb/8975c990a9e783c2289ef2114f486695364670 /usr/lib/debug/.build-id/cb/8975c990a9e783c2289ef2114f486695364670.debug /usr/lib/debug/.build-id/96/8a128a44fa7f76f95bf0ecd7800dba564a8bc4 /usr/lib/debug/.build-id/96/8a128a44fa7f76f95bf0ecd7800dba564a8bc4.debug /usr/lib/debug/.build-id/63/17b446423153db21a6716e4e145f29af08b007 /usr/lib/debug/.build-id/63/17b446423153db21a6716e4e145f29af08b007.debug /usr/lib/debug/.build-id/71/8492d52719e84029901376962ff9620e7a3dbe /usr/lib/debug/.build-id/71/8492d52719e84029901376962ff9620e7a3dbe.debug /usr/lib/debug/.build-id/44/eb2c59530af2b2f755d7d114dfdef20eb756fb /usr/lib/debug/.build-id/44/eb2c59530af2b2f755d7d114dfdef20eb756fb.debug /usr/lib/debug/.build-id/21/75d1b113b9f8e339c15ea5840aa7bac7ceb624 /usr/lib/debug/.build-id/21/75d1b113b9f8e339c15ea5840aa7bac7ceb624.debug /usr/lib/debug/.build-id/94/6d84f27a998230a351e7b9adead888ed5f43d6 /usr/lib/debug/.build-id/94/6d84f27a998230a351e7b9adead888ed5f43d6.debug /usr/lib/debug/.build-id/a7/ee31746ad44d4bfc84de31e123b725457fb583 /usr/lib/debug/.build-id/a7/ee31746ad44d4bfc84de31e123b725457fb583.debug /usr/lib/debug/.build-id/07/e41aa4d9dda1776934186e80360cc5498fbbf8 /usr/lib/debug/.build-id/07/e41aa4d9dda1776934186e80360cc5498fbbf8.debug /usr/lib/debug/.build-id/5e/db603c705535d870e5bb816d01d790c8cb51e1 /usr/lib/debug/.build-id/5e/db603c705535d870e5bb816d01d790c8cb51e1.debug /usr/lib/debug/.build-id/c9/5adf9e367e9547b158492b13bce3650e091ae5 /usr/lib/debug/.build-id/c9/5adf9e367e9547b158492b13bce3650e091ae5.debug /usr/lib/debug/.build-id/07/074e53e2d8d21f11273949ee9eb77a6cb564b5 /usr/lib/debug/.build-id/07/074e53e2d8d21f11273949ee9eb77a6cb564b5.debug /usr/lib/debug/.build-id/c3/06165f738800c035d8c40e8c3dbd4acbeb5878 /usr/lib/debug/.build-id/c3/06165f738800c035d8c40e8c3dbd4acbeb5878.debug /usr/lib/debug/.build-id/fe/7d50b1d80b01c4424ade892e2062238f9de097 /usr/lib/debug/.build-id/fe/7d50b1d80b01c4424ade892e2062238f9de097.debug /usr/lib/debug/.build-id/54/cde82706f4a620d502d2e2aef13d0b4e13fccc /usr/lib/debug/.build-id/54/cde82706f4a620d502d2e2aef13d0b4e13fccc.debug /usr/lib/debug/.build-id/3c/34a7256be7e0bdfc337a82f8b8621114d713ee /usr/lib/debug/.build-id/3c/34a7256be7e0bdfc337a82f8b8621114d713ee.debug /usr/lib/debug/.build-id/32/6161c58ab13b63570b0cefb1c5b40e0b129a29 /usr/lib/debug/.build-id/32/6161c58ab13b63570b0cefb1c5b40e0b129a29.debug
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
libxml2-2.7.7-1.fc14.x86_64
libxml2-debuginfo-2.7.7-1.fc14.x86_64
libstdc++-4.4.4-6.fc14.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
libgcc-4.4.4-6.fc14.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
zlib-1.2.5-1.fc14.x86_64
zlib-debuginfo-1.2.5-1.fc14.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
nss-softokn-freebl-3.12.4-22.fc14.x86_64
nss-softokn-debuginfo-3.12.4-22.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
glibc-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-ure-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
error: file /usr/lib64/openoffice.org3/share/uno_packages/cache/uno_packages/TkbryU_/pdfimport.oxt/pdfimport.uno.so: No such file or directory
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
error: file /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886: No such file or directory
error: file /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886.debug: No such file or directory
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
libxml2-debuginfo-2.7.7-1.fc14.x86_64
libxml2-debuginfo-2.7.7-1.fc14.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
gcc-debuginfo-4.4.4-6.fc14.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
zlib-debuginfo-1.2.5-1.fc14.x86_64
zlib-debuginfo-1.2.5-1.fc14.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
nss-softokn-debuginfo-3.12.4-22.fc14.x86_64
nss-softokn-debuginfo-3.12.4-22.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
glibc-debuginfo-2.12.90-2.x86_64
glibc-debuginfo-2.12.90-2.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
openoffice.org-debuginfo-3.2.1-19.7.fc14.x86_64
error: file /usr/lib/debug/.build-id/32/6161c58ab13b63570b0cefb1c5b40e0b129a29: No such file or directory
error: file /usr/lib/debug/.build-id/32/6161c58ab13b63570b0cefb1c5b40e0b129a29.debug: No such file or directory
[root@tlondon tmp]#

Comment 10 Tom London 2010-06-05 23:09:36 UTC
Sorry, downgrade to 3.2.1-19.6?

Comment 11 Tom London 2010-06-05 23:57:32 UTC
I downgraded all the openoffice.bin packages to -19.6 (including the debuginfo package), and now I get this:

[root@tlondon X200]# gdb core.6535 
GNU gdb (GDB) Fedora (7.1-24.fc13)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib64/openoffice.org/ure/bin/uno.bin...Reading symbols from /usr/lib/debug/usr/lib64/openoffice.org/ure/bin/uno.bin.debug...done.
done.
[New Thread 6541]
[New Thread 6546]
[New Thread 6547]
[New Thread 6535]
[New Thread 6539]
Missing separate debuginfo for /lib64/libfreebl3.so
Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/1f/2002828592d92a358e835ac56d6f85b6741ee8
Missing separate debuginfo for 
Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886
Reading symbols from /usr/lib64/openoffice.org/ure/lib/libuno_sal.so.3...Reading symbols from /usr/lib/debug/usr/lib64/openoffice.org/ure/lib/libuno_sal.so.3.debug...done.
done.
<<<<SNIP>>>>
Core was generated by `/usr/lib64/openoffice.org/basis3.2/program/../ure-link/bin/uno.bin --quiet --si'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007fdd75ffde20 in cppu::OInterfaceIteratorHelper::OInterfaceIteratorHelper (this=0x7fdd67ffe510, rCont_=...)
    at /usr/src/debug/OOO320_m19/cppuhelper/source/interfacecontainer.cxx:117
117			((XInterface *)pData)->acquire();
(gdb)


with no complaints about "filesystem".  Damn.

Notice the "Missing separate debuginfo for" with no file name......

The first one reports "No package ....." when I run the described "yum", but the second (the one with no file name) appears to pull in:

Dependencies Resolved

================================================================================
 Package                        Arch   Version           Repository        Size
================================================================================
Installing:
 kernel-debuginfo               x86_64 2.6.34-20.fc14    fedora-debuginfo 223 M
Installing for dependencies:
 kernel-debuginfo-common-x86_64 x86_64 2.6.34-20.fc14    fedora-debuginfo  35 M

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 258 M
Installed size: 1.5 G

Comment 12 Tom London 2010-06-06 00:06:06 UTC
Damn.  After installing the above kernel-debuginfo package, I can no longer reproduce this.

Some update between the report date and today must have changed something.....

Comment 13 Jan Kratochvil 2010-06-06 05:20:12 UTC
(In reply to comment #11)
> Missing separate debuginfo for 
> Try: yum --disablerepo='*' --enablerepo='*-debuginfo' install
> /usr/lib/debug/.build-id/5a/c6e51574d1809b287e5b6a246fe611614fa886

This one corresponds to the eu-unstrip line:
5ac6e51574d1809b287e5b6a246fe611614fa886 . - linux-vdso.so.1

> the second (the one with no file name) appears to pull in:
>  kernel-debuginfo               x86_64 2.6.34-20.fc14    fedora-debuginfo 223 

and linux-vdso.so.1 is really a part of kernel-debuginfo.

Sorry for not getting to it soon enough but currently it is not reproducible.

Comment 14 Jan Kratochvil 2010-06-06 09:49:07 UTC
Reproducer:
debuginfo-install coreutils
rpm -e kernel-debuginfo-common-x86_64 kernel-debuginfo
cd /
rm -f core.*
(ulimit -c unlimited;/bin/sleep 1h&p=$!;sleep 1;kill -SEGV $p)
gdb -c ./core.*
Missing separate debuginfos, use: debuginfo-install filesystem-2.4.31-1.fc13.x86_64

missing_rpm_enlist() gets called with filename "" for the vDSO which librpm resolves to the current directory (thus "cd /" is important there).
Bug will get fixed later as not a serious one, thanks.

Comment 15 Bug Zapper 2010-07-30 11:48:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.