Bug 599601 - Changing Evolution icon style is ignored
Summary: Changing Evolution icon style is ignored
Alias: None
Product: Fedora
Classification: Fedora
Component: gconf-editor   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2010-06-03 15:12 UTC by John Horne
Modified: 2011-06-27 17:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-06-27 17:26:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description John Horne 2010-06-03 15:12:37 UTC
Description of problem:
Using KDE on the desktop, but with the (gnome) Evolution mail client. If I use gconf-editor to set:

      /desktop/gnome/interface/toolbar_icons_size  'large-toolbar'
      /desktop/gnome/interface/toolbar_style       'both'

when I restart Evolution these settings are ignored. The toolbar in Evolution shows a small toolbar just with icons. Doing the same under F11, Evolution immediately shows a large toolbar, and the icons have text underneath them (the 'both' option). So it worked under F11, but doesn't in F13.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login specifying KDE as the desktop.
2. Invoke 'evolution' from a terminal. It will show a small toolbar just with icons.
3. From a terminal invoke 'gconf-editor'. Set the two settings above.
4, Restart Evolution. The toolbar has not changed.
Actual results:
Evolution toolbar does not change despite changing the settings.

Expected results:
Toolbar should change according to the settings. It worked in F11.

Additional info:
It does not matter whether I just restart Evolution, logout then login, or restart the whole computer system, the toolbar does not change.

The current toolbar icons are too small, and the 'delete' and 'junk' icons are *very* similar and right next to each other. This is obviously going to cause some mistakes. Using a large toolbar with icons and text makes them all bigger and spreads them out. The problem then goes away.

Apologies if this is not an actual gconf-editor problem, but I really couldn't work out where the problem lay.

Comment 1 Bug Zapper 2011-06-02 12:11:43 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Comment 2 Bug Zapper 2011-06-27 17:26:20 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.