Bug 59961 - anaconda installs files using wrong timezone
anaconda installs files using wrong timezone
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 19:18 EST by Michael Chapman
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Chapman 2002-02-15 19:18:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
During installation I believe anaconda is "using" the UTC time as the
current timezone. The timezone the user has selected is only applied the
next time the computer is rebooted. This means that files that were
created by anaconda or RPM during installation (such as via
post-installation scripts) have the "wrong" modified time on them.

I am in the Australia/Sydney timezone which is nominally GMT+10, but
since we are in summer it is currently GMT+11. My computer's clock is
running on local time, not UTC time. At 0849 (local time) the sendmail 
package was installed as part of a complete installation of Red Hat
Linux. At 0903 (local time) my computer was rebooted. When the startup
scripts came to starting up sendmail, it said:

make: Entering directory `/etc/mail'
make: *** Warning: File `virtusertable.db' has modification time in the future
(2002-02-16 19:49:05 > 2002-02-16 09:03:51)
make: warning:  Clock skew detected. Your build may be incomplete.
make: Leaving directory `/etc/mail'

This is because the file 'virtusertable.db', which was created by the
post-installation script for sendmail was saved with an mtime of 0849
(UTC time), which is 1949 (local time), rather than 0849 (local time).

The sendmail example is the most noticable effect of this problem; I
notice that it also affects other files created by RPM, such as
directories. Of course, it doesn't affect files that are installed by
RPM that are packaged as part of the RPM package itself, since RPM
packages store the mtimes for these files.

Anaconda should set the "current" timezone to what the user selected
immediately prior to copying files.

This problem would only affect users selecting a timezone in the 
eastern hemisphere (ie, GMT+x, _not_ GMT-x)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose a GMT+x timezone in anaconda
2. Complete the installation, and reboot
3. Look at mtimes of files such as

/etc/mail/virtusertable.db
/root/.
/.

(the last two being directories created by RPM)


Actual Results:  The files listed above have mtimes in the future.

Expected Results:  The files should have mtimes in the past.


Additional info:

Workaround:

Wait enough time before rebooting computer after installation; this
would allow enough time for those files to be in the past.

OR

Fix the mtimes of the files manually after rebooting.
Comment 1 Jeremy Katz 2002-02-19 02:07:59 EST
We can't always do this at present because we don't have all of the timezone
data available in, eg, ftp and http installs.
Comment 2 Michael Fulbright 2002-03-26 12:29:22 EST
Deferring to future release.
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.