Bug 599667 - [abrt] crash in gmixer-1.3-15.fc13: display.py:539:send_and_recv:ConnectionClosedError: Display connection closed by server: Connection reset by peer
[abrt] crash in gmixer-1.3-15.fc13: display.py:539:send_and_recv:ConnectionCl...
Status: CLOSED DUPLICATE of bug 596442
Product: Fedora
Classification: Fedora
Component: gmixer (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:c2801b36
:
: 605440 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 13:42 EDT by Samuel
Modified: 2010-06-17 18:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 18:50:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.59 KB, text/plain)
2010-06-03 13:42 EDT, Samuel
no flags Details

  None (edit)
Description Samuel 2010-06-03 13:42:37 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -OO /usr/bin/gmixer -d
component: gmixer
executable: /usr/bin/gmixer
kernel: 2.6.33.5-112.fc13.x86_64
package: gmixer-1.3-15.fc13
reason: display.py:539:send_and_recv:ConnectionClosedError: Display connection closed by server: Connection reset by peer
release: Fedora release 13 (Goddard)

backtrace
-----
display.py:539:send_and_recv:ConnectionClosedError: Display connection closed by server: Connection reset by peer

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/gtktrayicon.py", line 98, in reconnect_dock
    if self.update_manager_window(False):
  File "/usr/lib64/python2.6/site-packages/gtktrayicon.py", line 167, in update_manager_window
    xdisplay = self.get_xdisplay()
  File "/usr/lib64/python2.6/site-packages/gtktrayicon.py", line 161, in get_xdisplay
    xdisplay =  Xdisplay.Display(name)
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 112, in __init__
    info = self.query_extension(extname)
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 668, in query_extension
    name = name)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/rq.py", line 1428, in __init__
    self.reply()
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/rq.py", line 1440, in reply
    self._display.send_and_recv(request = self._serial)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/display.py", line 539, in send_and_recv
    raise self.socket_error
ConnectionClosedError: Display connection closed by server: Connection reset by peer

Local variables in innermost frame:
sending: 0
gotreq: 0
err: error(104, 'Connection reset by peer')
rs: [<socket._socketobject object at 0x2a13600>]
i: 16
self: <Xlib.display._BaseDisplay instance at 0x2962440>
req: <Xlib.protocol.request.QueryExtension serial = 6, data = None, error = None>
request: 6
flush_bytes: None
recieving: 1
ws: []
timeout: None
flush: None
wait: 1
recv: None
event: None
es: []
writeset: []
Comment 1 Samuel 2010-06-03 13:42:39 EDT
Created attachment 419464 [details]
File: backtrace
Comment 2 leigh scott 2010-06-04 16:04:02 EDT
Can you post steps to reproduce
Comment 3 William Volkman 2010-06-15 22:22:03 EDT
Package: gmixer-1.3-12.fc12
Architecture: i686
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Logout and then back-in.
2.
3.
Comment 4 leigh scott 2010-06-17 18:49:03 EDT
*** Bug 605440 has been marked as a duplicate of this bug. ***
Comment 5 leigh scott 2010-06-17 18:50:54 EDT

*** This bug has been marked as a duplicate of bug 596442 ***

Note You need to log in before you can comment on or make changes to this bug.