Bug 599672 - Dell Teak CAB-200 device not recognised in Fed 13 worked fine in Fed 12
Dell Teak CAB-200 device not recognised in Fed 13 worked fine in Fed 12
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 13:58 EDT by Anthony Name
Modified: 2010-06-18 15:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 16:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Name 2010-06-03 13:58:47 EDT
Description of problem:
The device just doesn't seem to get registered/detected correctly in Fedora 13

Version-Release number of selected component (if applicable):
Fedora 13 - Kernel 2.6.33.5-112.fc13.x86_64
Bluez 4.63-3
Bluez-libs 4.63-3
gnome-bluetooth-2.30.0-1
gnome-bluetooth-libs-2.30.0-1
How reproducible:
Device not recognised when starting System --> Preferences --> Bluetooth.  Error message in Gnome box reads "Your computer doesn't have any bluetooth adapters plugged in"

Steps to Reproduce:
1.  Reboot machine with controller installed
2.  Run System --> Preferences --> Bluetooth
3.
  
Actual results:
Error message as above


Expected results:
Bluetooth transceiver detected and provides Bluetooth services

Additional info:

lsusb and DMESG are showing the device as installed

lsusb

Bus 002 Device 006: ID 0644:0201 TEAC Corp.

dmesg

usb 2-1.3: new full speed USB device using ehci_hcd and address 5
usb 2-1.3: New USB device found, idVendor=046d, idProduct=0b05
usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1.3: Product: BT Mini-Receiver
usb 2-1.3: Manufacturer: Logitech
hub 2-1.3:1.0: USB hub found
hub 2-1.3:1.0: 3 ports detected
usb 2-1.4: new high speed USB device using ehci_hcd and address 6
usb 2-1.4: New USB device found, idVendor=0644, idProduct=0201
usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-1.4: Product: CAB-200
usb 2-1.4: Manufacturer: DELL
usb 2-1.4: SerialNumber: 000001034CC4


There are no related errors in /var/log/messages and restarting the bluetooth service injects no messages into the log.

I notice there are no bluez messages in dmesg which I would expect to see?
Also there's no bluetooth file in /etc/sysconfig which I would also expect to see, there is an appropriate bluetooth script in the /etc/rc.d directories.

Ideas please?
Comment 1 Anthony Name 2010-06-04 16:37:26 EDT
Sorry guys.

It turns out the specific CAB-200 I was using had developed a fault, when I switched it for another unit everything worked as it should.

Note You need to log in before you can comment on or make changes to this bug.