Bug 599691 - Alert Notification: have to click save each time you make a selection
Alert Notification: have to click save each time you make a selection
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
3.0.0
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On: 593218
Blocks: jon24-alert-notify
  Show dependency treegraph
 
Reported: 2010-06-03 14:47 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 593218
Environment:
Last Closed: 2011-03-24 09:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2010-06-03 14:47:44 EDT
+++ This bug was initially created as a clone of Bug #593218 +++

Description of problem:
While creating a new alert sender type, each time you make a selection, you have to click save, in order for more selections to appear.  For the Resource Operations type, this is 4 or 5 saves.

Version-Release number of selected component (if applicable):
Build# 152.

How reproducible:
Always

Steps to Reproduce:
1.Create a new alert definition.
2.Click on Edit for the Alert Notification.
3.On the Alert notification page, click on Add New. Select the Alert sender type as Resource Operations.
4.Select the resource selection mode as Relative Resource. 

  
Actual results:
Save button is shown - if you click it you have to reselect the Notification and then more form items are shown with another save button.  

Expected results:
All form items should be shown (either immediately or via ajax) and filled in before the user clicks save.  He should only have to click save once.

Additional info:
Comment 1 Joseph Marques 2010-06-10 05:23:30 EDT
commit 2674a1413dd7f6edaf2f4757d508125fdbabd6f5
Author: Joseph Marques <joseph@redhat.com>
Date:   Thu Jun 10 05:18:02 2010 -0400

    BZ-599691: automatically reselect the active notification each time "SAVE" is pressed
    
    figure out which one should be selected from the backing store.  updating
    an alert notification will overwrite all existing notifications with the
    latest data.  since the ids of the alert notifications are different after
    a save-action, but since we know what the updated data, we can select the
    correct one by testing for data equality (instead of pk/id equality).
Comment 2 Corey Welton 2010-06-10 14:04:19 EDT
Comment above was for different bug.  moving this one back to dev.
Comment 3 John Mazzitelli 2011-03-24 09:40:30 EDT
we won't fix this JSF view since our new GWT UI supercedes this and it doesn't have this problem.

Note You need to log in before you can comment on or make changes to this bug.