Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 599700 - Console examples sometimes fail due to not waiting for the broker connection to complete
Console examples sometimes fail due to not waiting for the broker connection ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
Development
All Linux
low Severity medium
: 1.3
: ---
Assigned To: Ted Ross
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 15:05 EDT by Ted Ross
Modified: 2011-08-12 12:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 09:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2010-06-03 15:05:37 EDT
Description of problem:

The 'ping' and 'console' examples in cpp/examples/qmf-console intermittently fail because they try to start operating against a broker that is not yet connected. 

Version-Release number of selected component (if applicable):


How reproducible:

very - the Ping example fails for me 100% of the time (i.e. the first ping doesn't go out)

Steps to Reproduce:
1. start a broker
2. run the "ping" example from cpp/examples/qmf-console
  
Actual results:

One of five pings are unsuccessful

Expected results:

All pings successful

Additional info:

This can also be seen using the 'console' example.  In this case, the example may not return any data.
Comment 1 Ted Ross 2010-06-03 16:26:22 EDT
Fixed upstream in revision 951141.

Note that a new method was exposed as public:  Broker::waitForStable()

This can be used after calling addBroker() to ensure that it is connected and stable prior to invoking getObjects, etc. on the session.

Note You need to log in before you can comment on or make changes to this bug.