Bug 599724 - sssd is broken on Rawhide
sssd is broken on Rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 15:46 EDT by Daniel Walsh
Modified: 2010-07-21 15:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.2.1-17.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sssd.log (233.00 KB, application/x-gzip)
2010-06-03 16:51 EDT, Daniel Walsh
no flags Details

  None (edit)
Description Daniel Walsh 2010-06-03 15:46:13 EDT
Description of problem:

 rpm -q sssd
sssd-1.2.0-12.fc14.x86_64


Basically if I 

service sssd restart

It forgets who I am.

whoami
whoami: cannot find name for user ID 3267


Causes ooffice to blow up also

ooffice 
[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 

(soffice:7360): GLib-WARNING **: getpwuid_r(): failed due to: Connection refused.

Not sure if this is broken in RHEL6 and F13
Comment 1 Daniel Walsh 2010-06-03 15:46:51 EDT
forward lookup seems to continue to work.

 id
uid=3267 gid=3267(dwalsh) groups=470(desktop_admin_r),1005,1070,3267(dwalsh),5356 context=staff_u:staff_r:staff_t:s0-s0:c0.c1023
Comment 2 Simo Sorce 2010-06-03 16:22:32 EDT
(In reply to comment #0)
> Description of problem:
> 

> ooffice 
> [Java framework] Error in function createSettingsDocument (elements.cxx).
> javaldx failed! 
> 
> (soffice:7360): GLib-WARNING **: getpwuid_r(): failed due to: Connection
> refused.
> 
> Not sure if this is broken in RHEL6 and F13    

We do not have any report like this so far.
Connection refused looks very weird though.
Can you check if you see errors in sssd_nss.log ?
Is this reproducible at will ?
Comment 3 Daniel Walsh 2010-06-03 16:51:56 EDT
Created attachment 420317 [details]
sssd.log

What triggered me restarting sssd in the first place, is that its log file had filled my entire disk, because steve had set it to level 9 debug.  When I saw this, I edited the /etc/sssd/sssd.conf file to turn it back to 0.

I did not remove the log file.  So sssd could have crashed because of out of disk space.
Comment 4 Fedora Update System 2010-06-21 07:51:45 EDT
sssd-1.2.1-15.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/sssd-1.2.1-15.fc13
Comment 5 Fedora Update System 2010-06-21 08:57:04 EDT
sssd-1.2.1-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sssd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sssd-1.2.0-13.fc13
Comment 6 Fedora Update System 2010-06-21 17:32:33 EDT
sssd-1.2.1-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sssd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sssd-1.2.1-15.fc13
Comment 7 Fedora Update System 2010-06-25 07:50:29 EDT
sssd-1.2.1-17.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/sssd-1.2.1-17.el5
Comment 8 Fedora Update System 2010-06-30 10:24:40 EDT
sssd-1.2.1-17.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sssd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sssd-1.2.1-17.el5
Comment 9 Fedora Update System 2010-07-07 13:53:01 EDT
sssd-1.2.1-15.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-07-21 15:59:33 EDT
sssd-1.2.1-17.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.