Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599732 - Root node in directory browser shows DN syntax error
Root node in directory browser shows DN syntax error
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.2.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 434914 389_1.2.6
  Show dependency treegraph
 
Reported: 2010-06-03 15:53 EDT by Nathan Kinder
Modified: 2015-12-07 12:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Patch (1.50 KB, patch)
2010-06-03 16:01 EDT, Nathan Kinder
nhosoi: review+
Details | Diff

  None (edit)
Description Nathan Kinder 2010-06-03 15:53:47 EDT
With 389 1.2.6.a4 and it's associated Console packages, selecting the top-level node in the tree on the left side of the "Directory" tab of the Directory Console results in an invalid DN syntax error being displayed in the right side panel.

The ns-slapd access log shows that console is sending a search like this when the root node is selected:

[03/Jun/2010:08:21:05 -0700] conn=10 op=21 SRCH dn="no LDAP connection", invalid dn
[03/Jun/2010:08:21:05 -0700] conn=10 op=21 RESULT err=34 tag=101 nentries=0 etime=0
Comment 1 Nathan Kinder 2010-06-03 16:01:14 EDT
Created attachment 419510 [details]
Proposed Patch

Clicking on the root node in the directory browser in DS console
shows a DN syntax error.  The root node is created with a bogus
DN of "no LDAP connection".  This was being used as a search base
in an attempt to find child entries to display in the right hand
panel of the directory browser.

The fix is to avoid searching for child entries of the root node
since the root node itself doesn't actually represent an LDAP
entry.
Comment 2 Nathan Kinder 2010-06-03 16:10:04 EDT
Pushed to master.  Thanks to Noriko for her review!

Counting objects: 17, done.
Delta compression using 2 threads.
Compressing objects: 100% (6/6), done.
Writing objects: 100% (9/9), 1011 bytes, done.
Total 9 (delta 4), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds-console.git
   bf23aae..01ddc9c  master -> master

Note You need to log in before you can comment on or make changes to this bug.