Bug 599733 - installer doesn't tell me the db schema exists
installer doesn't tell me the db schema exists
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
3.0.0
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-06-03 15:54 EDT by John Mazzitelli
Modified: 2011-02-17 12:47 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 12:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2010-06-03 15:54:09 EDT
Description of problem:

Upgrading from a previous version, and pointing the installer to the default DB settings, the installer didn't tell me that the db schema exists (and thus doesn't give me the drop down menu to pick if I want to overwrite or keep nor the drop down menu to say if this is a new server or an existing registered server. The only way for me to get them is to explicitly click the Test Connection button.

How reproducible:

Install an old version of the server, get it running (I used the default postgres settings that come out of box - postgres on localhost, rhq database name and rhqadmin/rhqadmin as the credentials). Then shut it down, and install the new version. Go to the installer and see that you aren't told that the schema already exists nor can you tell you if you want this to be a new server or register it as one of the alerady existing ones. Then click the Test Connection button (without touching anything else) and see you get the drop down menus.
Comment 1 Charles Crouch 2010-07-06 19:59:09 EDT
So what changed from 2.3.1? This would only have ever work for databases using the default username and password correct? Perhaps we just need an extra line in the UI saying "Please hit the Test Connection button to determine if you already an existing db schema at this location". The key thing to avoid is allowing people to overwrite existing schemas unwittingly.
Comment 2 John Mazzitelli 2010-07-09 12:08:24 EDT
this might not be a problem - I need to go back and check. Its possible that I wasn't connected to the database with the correct password and thus wasn't able to see the DB schema.
Comment 3 John Mazzitelli 2010-07-09 12:12:19 EDT
yeah, ok, this isn't a problem. At the most, we could do charles' suggestion, "an extra line in the UI saying "Please hit the Test Connection button to determine if you already an existing db schema at this location". lowering priority since this appears to be a minor annoyance.

Note You need to log in before you can comment on or make changes to this bug.