Bug 59975 - script error: named.conf not created if it does not exist
script error: named.conf not created if it does not exist
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-17 01:46 EST by Robert L. Cochran Jr.
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-17 01:46:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert L. Cochran Jr. 2002-02-17 01:46:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
This report is relevant to the bind.spec file for bind-9.1.3-4.The %post code
contains this:

if [ -f /etc/named.boot -a ! -f /etc/named.conf ]; 
...

New installations will not have the file named.boot since it is only relevant to
BIND version 4. You won't have a named.conf file in a new installation either,
so the script will fail and you won't have an /etc/named.conf file to start out
with.This package does not require named.conf to be present from another
package. This package also does not require or provide the root hints file or
sample zone files (such as one for localhost.)

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
Please see below for commentary.

Actual Results:  If /etc/named.conf and /etc/named.boot are not present, then
/etc/named.conf is not generated. When BIND then attempts to start, it will choke.

Missing /var/named zone files will also cause BIND to choke.

Expected Results:  An /etc/named.conf file valid for the packaged BIND version
should be installed or the existing named.conf file should be preserved. Sample
zone files should also be installed.

Additional info:

I am adding BIND version 9.2.0 rather than Red Hat's 9.1.3-4 release using a
downloaded source tarball. This is the first time that BIND is installed on this
workstation. To figure out where the binaries get installed, I examined the spec
file from the Red Hat RPM distribution for bind-9.1.3-4. It contains the script
code cited above. I did a ./configure and 'make' on the 9.2.0 source tree and
then ran the script code, with modifications to remove RPM_BUILD_ROOT and the
documentation installs, starting at %install.
Comment 1 Bernhard Rosenkraenzer 2002-02-20 09:12:00 EST
This is intentional. 
The %post script will just convert an old named.boot file to a named.conf file if it 
existed. 
 
Since we have no way of foretelling which domains you're trying to host, creating a 
"standard named.conf" would be pointless. 
 
If you're looking for a named.conf example, install the caching-nameserver package.

Note You need to log in before you can comment on or make changes to this bug.