Bug 599761 - FTBFS gtkglarea2-1.99.0-11.fc12: ImplicitDSOLinking
Summary: FTBFS gtkglarea2-1.99.0-11.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkglarea2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
: 564760 (view as bug list)
Depends On:
Blocks: F14FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-06-03 20:21 UTC by FTBFS
Modified: 2010-07-08 07:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 07:40:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (422.07 KB, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details
build.log (29.67 KB, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details
mock.log (986 bytes, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details
root.log (628.84 KB, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details
build.log (34.13 KB, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details
mock.log (917 bytes, text/plain)
2010-06-03 20:21 UTC, FTBFS
no flags Details

Description FTBFS 2010-06-03 20:21:05 UTC
gtkglarea2-1.99.0-11.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-06-03 20:21:08 UTC
Created attachment 419581 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-06-03 20:21:09 UTC
Created attachment 419582 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-06-03 20:21:11 UTC
Created attachment 419583 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-06-03 20:21:13 UTC
Created attachment 419584 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-06-03 20:21:14 UTC
Created attachment 419585 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-06-03 20:21:15 UTC
Created attachment 419586 [details]
mock.log

mock.log for x86_64

Comment 7 Richard W.M. Jones 2010-07-08 07:40:11 UTC
I fixed this in Rawhide yesterday.

Comment 8 Richard W.M. Jones 2010-07-08 07:40:52 UTC
*** Bug 564760 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.