Bug 599797 - FTBFS qmpdclient-1.1.3-2.fc13: ImplicitDSOLinking
FTBFS qmpdclient-1.1.3-2.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qmpdclient (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Julian G
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F14FTBFS
  Show dependency treegraph
 
Reported: 2010-06-03 16:30 EDT by FTBFS
Modified: 2010-06-23 13:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: qmpdclient-1.1.3-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 13:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (539.97 KB, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details
build.log (197.95 KB, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details
mock.log (903 bytes, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details
root.log (824.35 KB, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details
build.log (192.10 KB, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details
mock.log (988 bytes, text/plain)
2010-06-03 16:30 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-06-03 16:30:29 EDT
qmpdclient-1.1.3-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-06-03 16:30:32 EDT
Created attachment 419766 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-06-03 16:30:34 EDT
Created attachment 419767 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-06-03 16:30:35 EDT
Created attachment 419768 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-06-03 16:30:37 EDT
Created attachment 419769 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-06-03 16:30:38 EDT
Created attachment 419770 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-06-03 16:30:39 EDT
Created attachment 419771 [details]
mock.log

mock.log for x86_64
Comment 7 Julian G 2010-06-05 14:00:06 EDT
fixed in 1.1.3-3

build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2232643
Comment 8 Fedora Update System 2010-06-05 14:02:24 EDT
qmpdclient-1.1.3-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qmpdclient-1.1.3-3.fc13
Comment 9 Fedora Update System 2010-06-07 18:27:01 EDT
qmpdclient-1.1.3-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qmpdclient'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/qmpdclient-1.1.3-3.fc13
Comment 10 Fedora Update System 2010-06-23 13:51:22 EDT
qmpdclient-1.1.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.