Bug 599801 - FTBFS rb_libtorrent-0.14.8-2.fc13: ImplicitDSOLinking
Summary: FTBFS rb_libtorrent-0.14.8-2.fc13: ImplicitDSOLinking
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rb_libtorrent (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Peter Gordon
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: F14FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-06-03 20:31 UTC by FTBFS
Modified: 2010-06-04 00:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 00:56:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (151.84 KB, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details
build.log (369.88 KB, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details
mock.log (918 bytes, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details
root.log (219.31 KB, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details
build.log (358.51 KB, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details
mock.log (926 bytes, text/plain)
2010-06-03 20:31 UTC, FTBFS
no flags Details

Description FTBFS 2010-06-03 20:31:08 UTC
rb_libtorrent-0.14.8-2.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-06-03 20:31:11 UTC
Created attachment 419787 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-06-03 20:31:12 UTC
Created attachment 419788 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-06-03 20:31:14 UTC
Created attachment 419789 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-06-03 20:31:15 UTC
Created attachment 419790 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-06-03 20:31:16 UTC
Created attachment 419791 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-06-03 20:31:17 UTC
Created attachment 419792 [details]
mock.log

mock.log for x86_64


Note You need to log in before you can comment on or make changes to this bug.