Bug 599844 - FTBFS PyQt4-4.7.3-2.fc14
FTBFS PyQt4-4.7.3-2.fc14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PyQt4 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: F14FTBFS
  Show dependency treegraph
 
Reported: 2010-06-03 16:38 EDT by FTBFS
Modified: 2010-06-11 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 12:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (598.95 KB, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details
build.log (1.20 MB, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details
mock.log (960 bytes, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details
root.log (899.30 KB, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details
build.log (1.14 MB, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details
mock.log (968 bytes, text/plain)
2010-06-03 16:38 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-06-03 16:38:32 EDT
PyQt4-4.7.3-2.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-06-03 16:38:35 EDT
Created attachment 420022 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-06-03 16:38:38 EDT
Created attachment 420023 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-06-03 16:38:40 EDT
Created attachment 420024 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-06-03 16:38:42 EDT
Created attachment 420025 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-06-03 16:38:44 EDT
Created attachment 420026 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-06-03 16:38:46 EDT
Created attachment 420027 [details]
mock.log

mock.log for x86_64
Comment 7 Rex Dieter 2010-06-11 10:11:19 EDT
Looks like phonon module fails,

Checking to see if the phonon module should be built...
g++ -DQT_NO_DEBUG -DQT_PHONON_LIB -I. -I/usr/lib64/qt4/mkspecs/default -I/usr/include/phonon -I/usr/include -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2  -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -w -D_REENTRANT cfgtest_phonon.cpp -o cfgtest_phonon -Wl,-O1 -lphonon -lpulse-mainloop-glib -lQtDBus -lQtXml -lQtGui -lQtCore -lpthread
/usr/bin/ld: cannot find -lpulse-mainloop-glib
collect2: ld returned 1 exit status

need to find out where the -lpulse-mainloop-glib is coming from.

Ugh, here it is:
%{-libdir}/libphonon.prl:QMAKE_PRL_LIBS =  -lpulse-mainloop-glib -lQtDBus -lQtXml -lQtGui -lQtCore
Comment 8 Rex Dieter 2010-06-11 10:22:47 EDT
Cross your fingers,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2245023
Comment 9 Rex Dieter 2010-06-11 12:47:42 EDT
build finished.

Note You need to log in before you can comment on or make changes to this bug.