Bug 599865 - FTBFS gtest-1.4.0-1.fc13: ImplicitDSOLinking
Summary: FTBFS gtest-1.4.0-1.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtest (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: F14FTBFS
TreeView+ depends on / blocked
 
Reported: 2010-06-03 20:42 UTC by FTBFS
Modified: 2010-08-28 10:08 UTC (History)
2 users (show)

Fixed In Version: gtest-1.4.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-28 10:08:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (18.67 KB, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details
build.log (29.33 KB, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details
mock.log (960 bytes, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details
root.log (21.77 KB, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details
build.log (29.20 KB, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details
mock.log (891 bytes, text/plain)
2010-06-03 20:42 UTC, FTBFS
no flags Details

Description FTBFS 2010-06-03 20:42:32 UTC
gtest-1.4.0-1.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-06-03 20:42:34 UTC
Created attachment 420145 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-06-03 20:42:36 UTC
Created attachment 420146 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-06-03 20:42:37 UTC
Created attachment 420147 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-06-03 20:42:38 UTC
Created attachment 420148 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-06-03 20:42:39 UTC
Created attachment 420149 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-06-03 20:42:40 UTC
Created attachment 420150 [details]
mock.log

mock.log for x86_64

Comment 7 Bug Zapper 2010-07-30 11:55:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.